Firmware load error capacitive touch 7'' display

I got one of the 7’’ cap touch displays you have in store to test a couple of things for my app. I enabled two device tree overlays:

After enabling the overlays, I rebooted and ran dmesg and got the following error back:

[ 9.058065] atmel_mxt_ts 1-004a: Family: 164 Variant: 11 Firmware V1.2.AA Objects: 41

[ 9.143487] atmel_mxt_ts 1-004a: Direct firmware load for maxtouch.cfg failed with error -2

[ 9.154413] atmel_mxt_ts 1-004a: Touchscreen size X799Y479

Am I missing something?

I forgot to add that I am using an Aster board. Tried this already and did not work.

HI @jaimeibk

Could you provide the software version of your module?

Best regards,

Hi, @jaski.tx !

I am on Torizon 4.0.0-dev-20191209+build.34
kernel 5.4.2



The messages is shown because the Atmel MXT touchscreen driver tries to load a config to configure the touchscreen chip. However, the touchscreen controllers we are using in our screens already have a reasonable default config. So there is no need for a specific configuration. Hence this message can safely be ignored.

How can I test if it is indeed working? I am trying to test it with the Crank Software container and the display does not respond.

I do see the touchscreen device under /dev/input/touchscreen0. However, I get no output after running sudo cat /dev/input/touchscreen0.

Hi, @stefan.tx

Just wondering about follow up on this issue.


Hi @jaimeibk,

I assume the issue is that one of your overlays is specific to the aster carrier board but by default Torizon loads and uses the evaluation board device tree which would cause this overlay to not work as intended. Unfortunately Torizon currently only ships with the evaluation board device tree. I will bring this up internally to see if we can resolve this by shipping both device trees so you can switch on the fly.

Thanks, @jeremias.tx !
I will test this out with the EVB anyway tomorrow.

I could switch device trees in u-boot, am i right? Could that be another option?

There is no Aster specific device tree in TorizonCore currently.

However, the overlay should make the touchscreen work for the Aster carrier board. I would recommend using evtest to test if you get input events. You can use the Weston container (which also should forward the input devices inside the container properly), use docker exec to create a second shell inside the container and use apt-get install evtest to get evtest inside the container.

hi @jaimeibk: Is the issue solved now?