Ethernet connection stuck on Colibri iMX7D

Hi. We are using the iMX7D module on a custom carrier board. Sporadically the ethernet connection stuck after reboot. The behavior is exactly the same as described in ticket 43611. The ethernet LEDs are blinking but no connection can be established. The dmesg output contains lot of “ifdown/ifup” events. Our image is based on BSP version 2.8.5 so the bug 43611 should be already fixed, right?
Now the question is if the issue is SW or HW related. The ticket description states that disabling the PHY power-down bit could be helpful. How could this be done (for testing)? Our carrier design is based on your reference designs and most of the ethernet stuff is handled on the Colibri module itself. Maybe there are special requirements for the power-up and power-down sequence we are not aware of? Thanks in advance.

Hi qojote,

Our Ticket #43611 that you mentioned turned out to be caused by Errata [1] “Module 1:Receiver error…” of the KSZ8041 PHY. There it is suggested to not use the software power down feature. We did that with the commit f940eb07812 [2]. That one is already in for BSP 2.8b5 and we haven’t seen that problem since then.

power-up and power-down sequence for the PHY that is on the module is handled on the module itself.
Please make sure the patch [2] is in your image. If the problem persists please try to reproduce it with a stock BSP from us and share how exactly you reproduced this problem and how it appears to you.

Some questions from my side that are not 100% clear:
Which reference design did you took to design your carrier board?
Are you using the ethernet PHY that is populated on the module or do you have one on your carrier board?

[1] http://ww1.microchip.com/downloads/en/DeviceDoc/80000700A.pdf

[2] http://git.toradex.com/cgit/linux-toradex.git/commit/drivers/net/phy?h=toradex_4.9-2.3.x-imx-next&id=f940eb07812d80e97334af932e9e1e3a224b4734

We took the Viola carrier board schematics as base for our carrier board. We are using the ethernet PHY on the Colibri module. The issue can be seen with our custom image and with the 2.8.6 LXDE demo image. I have created a new ticket to discuss the proper power-up sequence.

Thanks for your Input. We will follow up the discussion in the new ticket.

Best regards,
Jaski

Problem solved. After a closer inspection of our custom carrier we found a problem in the filter stage of the RX/TX. Thanks for your held.

Perfect that the issue is solved. Thanks for the feedback.