Ethernet 2 is not Detecting on iMX8M Plus SOM custom Board

Dear Team,

We have designed a custom board based on iMX8M Plus SOM. We have two Ethernet, Ethernet 0 is directly from SOM module and Ethernet 1 through PHY (KSZ9031RNXIC).

We have installed TorizonCore with evaluation containers and tried to establish SSH connection. Through Ethernet 0, we are getting the connection but through Ethernet 2 not getting the connection.
We tried ifconfig command, in that only Ethernet 0 is showing.

We have checked this with Verdin Development board(same SOM Module), there through both Ethernet connection established.

Let me know what will be root cause of this.

Thanks

Hi @vkj ,

Thanks for posting toToradex Community

Regarding your question, we will need more information to understand complete setup before we can provide any response. Please help us with below:

  • Complete hardware and software detail like Module exact version and TorizonOS version you are working with.

  • Output of dmesg ,tdx-info, ip addr in txt format

  • Have you done any device tree modification ?

  • Schematic to check connection(if you are not comfortable sharing schematic on community, you can send us at support.in@toradex.com)

Best Regards
Ritesh Kumar

Dear Ritesh,

Module I am using : VERDIN iMX8M PLUS QUAD 4GB IT

Here attaching the specified documents you mentioned.
carrier ifconfig.txt (3.4 KB)
dmesg.txt (51.9 KB)
ip addr.txt (2.6 KB)

I have not done any device tree modification.

Schematic I have mailed you.

Thank you

Hi @vkj,

Thanks for sharing logs. Also we have received schematic, allow us some time to check and get back to you.

Best Regards
Ritesh Kumar