Erros while building meta-toolchain-qt5

link textI am building linux image for T20 with latest v2.7 branch.
while building - bitbake -k meta-toolchain-qt5 compilation is done successfully but In the last step It is showing errors:
I am attaching log file.

I also got some errors with this process. I would like to know how you have started this process ( I did not used yocto build process) . Can you tell me in detail so that it will be useful to find whether there’s any difference in our proceedings ?. Also I have attached the log file here and I think I got something different. link text

I referred this link of oe-core setup and tool chain building link text

I also followed the same link… It seams that something is broken angstrom-qt5-x11-image is building without any problem with -c populate_sdk option

Have you tried this one bitbake -k angstrom-qt-x11-image . I don’t get any errors for this. But I’m unable to compile the application using the qmake2 which was obtained at the end of this process.

I am using qt5 image and successfully compiling application from commandline with cross compiler

I’m struggling with the cross compilation for past few days. I’m unable to achieve my goal. If possible, please send me a text file which contains the chronological order on which the commands have to be executed in development machine to build qt5 image. It will help me a lot.

I’ve just tried fresh download and compile using this commands:

repo init -u -b LinuxImageV2.7-next
repo sync
source ./export
bitbake angstrom-qt5-x11-image
bitbake -k meta-toolchain-qt5

It worked correctly on Ubuntu 16.04.3 LTS, For now I can only suggest trying from scratch again, maybe there was some issue during sync or some issue with your hw.

should I need to delete Downloads folder and sstate-
cache folder which I used from previous builds?

It should be OK for those folders to stay, make sure you remove all others in build and preferably entire deploy directory.