Error while flashing easy installer into Apalis Imx8

I have a problem with Apalis iMX8, I am trying to flash the easy installer inside but the HDMI is showing a blank screen, I understand that it will not show anything till the easy installer is flashed.

However, I am getting the following error (libusb error timeout), in addition to the excessive heat coming up from the processor and the fan isn’t working as well so I am not sure this is a hardware failure? OR there is some sort of reset needed.

I have 2 similar Apalis iMX8 and they are working normally, I am only getting this error from this one and this excessive heat is worrying me as well.

Does anyone have any suggestions??

I disconnected the SoM, changed the cable, changed the laptop, tried Ubuntu and Windows, and still the same case.

Moreover, I can see the USB in Ubuntu device >> NXP … etc But still get the same error at 20%.

Hi, @mserour !

What is the exact version of your module?

Best regards,

Hi Henrique,

This one Apalis iMX8 QuadMax 4GB Wi-Fi / Bluetooth IT.

Any suggestions for debugging steps?

Hi @mserour !

Please, inform the full name and the version, like it is on the module’s label.

Best regards

Hi Henrique,

You mean the numbers attached on the model label in the photo right?