Error Running recovery-linux.sh for Apalis TK1 V1.2A on a Raspberry Pi

Hello,

I am running the recovery-linux.sh command from the EasyInstall pack for our Apalis TK1 board which is connected to an Ixora carrier board. I am running the command from an Ubuntu Mate desktop (running on a Rasberry Pi) with the Ixora connected via the X9 USB port with JP2 removed (as per the guide).

I continue to get the same error indicating the following:

“./tegrarcm: 1: ./tegrarcm: Syntax error: “(” unexpected”

Could you please advise as to how I could resolve seeing this issue so I can continue facory resetting our board back to a base OS build.

Many thanks in advance.

Could you please specify version of TEZI you are using?
And I’d recommend to download the latest TEZI from our website - https://developer.toradex.com/software/toradex-easy-installer#load-toradex-easy-installer

Thanks for the response.

I can confirm I downloaded the latest version on the website which was v1.7 for Apalis TK1.

Currently, as a host machine for Toradex Easy Installer recovery only x86 resp. x86_64 PCs are supported out-of-the-box. However, should you replace resp. required binaries with suitable ones for your architecture it may of course work on different host machines as well. In the Apalis T30 resp. Apalis TK1 case the binary in question would be tegrarcm which is also exactly what the error message you are getting suggests.

Running the tool upon an x86_64 based Ubuntu desktop worked fine.

Thanks for the support.

You are welcome. Thanks for the feedback.