Error reading OS Image from flash

Hello,
I have a following problem with VF61:

Error reading OS Image from flash.

For more details see the image

1327-cattura.png.

This problem occurred after trying to update OS.
I want to know how can I repair this board.
Thank you
Matteo

Dear @Matte

The following article on the developer pages describes how to flash Windows CE.

Your bootloader (Eboot) is still working, so you will be able to take some shortcuts while following the instructions.

Regards, Andy

Dear @andy.tx,
thank you for your answer.
When I did flashloader, the board found only two blocks,

while on the documentation there are 3 blocks.
Is it correct?

When I did flashimage nk7.bin the following message happens:

Cannot find a free block for the image 

in the following image you can show the log file.
1336-cattura.png

Dear @Matte

We optimized the bootloader update procedure, so it is expected that only two blocks are erased.

The available space for the os image is defined in the bootloader config block. Try to display the current setting, and revert it to factory defaults (64MB). Your terminal should look like this (an asterisk * marks settings which differ from hard-coded defaults):

>set
Config List:
  mac:          Ethernet MAC Address
  ip:           IP Config
* boot:         Boot Config
  ser:          Serial Port Config
  gpio:         GPIOs Config
  hw:           HW Version
* dbg:          Debug Config
  ss:           SplashScreen Config
  pt:           Production Tester
  karg:         Kernel Arguments
  part:         Partition Config
  mem:          Memory Config
  patch:                HW Register Patch

>set part
part.nonfssize: 64              (Size of the non-filesystem partition (in MB))

>clear part
Finding bootargs block...
Writing 5 sector(s) of bootargs data from sector 320.
GPIO configuration found.

Regards, Andy

Dear @andy.tx,

I used your commands,
when I did clear part the board responsed with empty line

see the following image

Is it correct?
Best regards
Matteo

Dear @Matte

The empty response is fine:
As you can see in your screenshot, the block part is not saved (no asterisk * in front of it). Therefore the clear part does not need to do anything.

If you still can’t flash the image, I fear the module is broken.
In this case, please fill in the RMA form to let us repair or replace the module. By default, we might get back to you with questions whether you tried to do software fixes. Just refer to this ticket to avoid answering similar questions again.

Best Regards,
Andy

Dear @andy.tx

I have the same problem with a Colibri VF50 module. Are there further solutions to solve the problem now. I have tried all the things you have suggested.

Thanks in advance and best regards
Georg

Dear @Georg

Would you mind opening a new ticket? It might be the same issue, but we’re not sure, so it is easier to keep the communication focused on one particular problem.
I would also appreciate if you could enable the debug messages and send me the full log output from the serial port.
I hope it will allow us to do an initial diagnosis and check whether it is required to send the module back to us.

Regards, Andy