Error in reading iRQ status of spi1.1 for apalis TK1

Hello,
After booting my apalis TK1 V1.1A from the flash or from my SD card , I always get this following notification :

apalis-tk1-k20 spi1.1: Failed to read IRQ status: -5

I don’t know where the problem could come from ou how can I correct it .
Thanks

PS : I use an Ixora Board V1.0A and Ubuntu 16.04 64 bit

Can you share dmesg and lsmod outputs?
What software are you using on the module?
What’s the output after unloading all modules with k20 in name and then loading apalis_tk1_k20 module?

Can you provide entire output from dmesg as a regular text?

Hello,
i’m sorry for the late but I was trying to figure out how to extract the entire dmesg output.
Now I got the file and I’ll send it to you right now .link text

Thanks,

Regards

From the kernel log I noticed that you are running your own build. Have you ever tried it with any of our official binary BSP demo images?

Indeed I also tried with the images I found in the toradex site and also the images I built with openembedded core and the bitbake command.
But the same problem display repeats itself.

Please flash our latest BSP and follow this steps:

  1. Make a backup of firmware file

    cp /lib/firmware/apalis-tk1-k20.bin /lib/firmware/apalis-tk1-k20.bin.bkp

  2. Perform K20 full erase described here

  3. Restore firmware from backup

    cp /lib/firmware/apalis-tk1-k20.bin.bkp /lib/firmware/apalis-tk1-k20.bin

  4. Execute poweroff command and disconnect power to the board after power down for 5 minutes.

thank you ,

my following question can seem obvious but where can I find the latest BSP ? isnt it the same as the one which is given in this link Flashing Embedded Linux to Tegra Modules ?

Regards

I did the steps but the problem is still here

Are you using resistive touchscreen? Does it reproduce around the same time after every boot or is it more random? Unfortunatelly I’m currently out of office, so any deep investigation will happen next week. Our BSP images can be found here Latest one is 2.7b2

I plan to use a touchscreen from toradex it is the touch display 7", I’ve just linked it with my Ixora board but haven’t use it yet.
Concerning the display of the spi1.1 problem, it is not random and is occuring around the same time after every boot (appearing 3min after the boot).
For the BSP , i have the 2.7b1 the one from january.
Thanks , will you be at office Monday ?

Please note that currently none of our displays may be used together with Apalis TK1 on Ixora as they all rely on parallel RGB which is not available on Apalis TK1. That said at least the current 10 inch multi-touch one would theoretically be a compatible single channel LVDS display however you would require a special cable to directly connect it to Ixora via LVDS rather than via parallel RGB going through the separate converter PCB.

And yes, @dominik.tx should be back in the office on Monday.