EMMC is not disabling in our custom board which is runing on T30 SOM

Hi,

We have a custom carrier board which is running on T30 SOM. For our required i want to configure “TEGRA_GPIO_PV3” GPIO (whcih default configured for “MMC1_CD_N” with 171 GPIO number) as an interrupt. So to configure the TEGRA_GPIO_PV3 have disabled the EMMC from the kernel menuconfig. Please find the attached screeshot (EMMC_Menuconfig)alt text.

After flashing the EMMC disabled kernel, board is not booting (waiting for the EMMC device) and getting hung with the message “Waiting for root device /dev/mmcblk0p2…”

Please find the attached kernel config changes (EMMC_Menuconfig) to disable the EMMC and the boot up logslink text.

So is there any other place to completely disable the EMMC?

Note: Below are the hardware and software setup details:
1)hardware :- T30 SOM + custom Carrier board
2) Software versions :- Linux apalis-t30 3.1.10

Hi deepak

You cannot disable the EMMC on a Apalis T30, since the uboot and linux image in stored there. Only on modules which have raw nand flash, you can disable emmc.

Best regards, Jaski

Hi Jaski,

Thank you for the reply.

Hi Jaski,

We have utilized all the GPIOs available in the SOM module. During this process we have connected some GPIOs to standard interfaces by looking the data sheet which mentioned as standard GPIO. In the same process as we are not using SD card in our design we used card detect pin as external interrupt (GPIO). In the same way we assumed that internal eMMC flash does not required card detect, we used MMC1_card detect pin also. Please confirm whether our assumption is correct. In that case is it possible to use the MMC1_ card detect as external interrupt (GPIO)?

Please find attached screen shot from the apalis t30 datasheetalt text.

Awaiting for the reply.

hi deepak, your assumption is correct.
You can use the toradex pinout designer, which is available for windows. This tool will help you to choose the correct pins for your pins easily.

Hi Jaski,

Thank you.
I am able to reconfigure the required GPIO’s.

Hi deepak,

Perfect.