EIM burst mode causes the system to freeze


Now the EIM interface works in asynchronous mode the next step is to use it in (synchronous) burst mode. However when I enable this mode by changing the second and third bit (SWR and SRD) of the first register using devmem2 0x21b8000 it freezes after I try to access the memory in the given region (set from 0x500000000, which can be accessed in asynchronous mode). As an example: # devmem2 0x50000000 “returns /dev/mem/ opened” and the consoles freezes.

Since it is said that this problem occurs often due to an unreferenced clock, I tried to rule it out by adding a line imx6ull-colibri-eval-v3.dtsi device tree that enables all clocks:

	chosen {
		bootargs = "clk_ignore_unused";

But that did not change anything. Is there a way to check whether this is actually executed by the bootloader?

The extra signals that are used in this mode of operation are also referenced in the pinmuxc and enabled:

cat /sys/kernel/debug/pinctrl/pinctrl-handles

    type: CONFIGS_PIN controller 20e0000.iomuxc pin MX6UL_PAD_NAND_DQS (110)config 0001b060
    type: CONFIGS_PIN controller 20e0000.iomuxc pin MX6UL_PAD_NAND_WP_B (105)config 0000b0b1

What could be the cause of this problem?



It was solved by adding the eim clock from the dt bindings include in the device tree.