Easy Installer: "claim interface failed"

My development environment
Easy Installer: toradex_easy_installer_colibri_imx6_0.6beta
Colibri Evaluation Board V3.2
Modul: iMX6DL 512MB V1.0A with WCE 2013 Bootloader/Image 1.2b4

Recovery Mode is activ. CMD - recover-windows.bat:

D:\work\iMX6\easyinst>recovery-windows
config file <recovery\\\imx_usb.conf>
vid=0x15a2 pid=0x0054 file_name=mx6_usb_rom.conf
-> vid=0x1b67 pid=0x4fff file_name=mx6_usb_sdp_spl.conf
-> vid=0x1b67 pid=0x4000 file_name=mx6_usb_sdp_uboot.conf
vid=0x15a2 pid=0x0061 file_name=mx6_usb_rom.conf
-> vid=0x1b67 pid=0x4fff file_name=mx6_usb_sdp_spl.conf
-> vid=0x1b67 pid=0x4000 file_name=mx6_usb_sdp_uboot.conf
config file <recovery\\\mx6_usb_rom.conf>
parse recovery\\\mx6_usb_rom.conf
Trying to open device vid=0x15a2 pid=0x0061
Interface 0 claimed
HAB security state: development mode (0x56787856)
== work item
filename SPL
load_size 0 bytes
load_addr 0x13f00000
dcd 0
clear_dcd 0
plug 0
jump_mode 3
jump_addr 0x00000000
== end work item

loading binary file(SPL) to 00907400, skip=0, fsize=bc00 type=aa

<<<48128, 48128 bytes>>>
succeeded (status 0x88888888)
jumping to 0x00907400
config file <recovery\\\mx6_usb_sdp_spl.conf>
parse recovery\\\mx6_usb_sdp_spl.conf
Trying to open device vid=0x1b67 pid=0x4fff
claim interface failed
Drücken Sie eine beliebige Taste . . .

TeraTerm shows the following output:

Commercial temperature grade DDR3 timings, 64bit bus width.
Trying to boot from USB SDP
SDP: initialize...
SDP: handle requests...

Then i tried an 2.0 USB-Hub and another Laptop, but always the same error. What more can I do to load Easy Installer successfully? Thanks in advance.

Hm, in that state, when it says “SDP: handle requests”, is the device appearing in the device manager?

After Trying to open device vid=0x1b67 pid=0x4fff, is claim interface failed immediately printed or with some delay?

Hi Stefan, please have a look at the video i made. link text

Thanks for the Video. This is Windows 7 is that correct? I just tried it on a Windows 7 machine here, I could not reproduce the issue. Altough, USB issues can be somewhat machine specific.

It seems to me as if your system tries to communicate too early, so I added a delay before claiming the USB interface. Please replace imx_usb.exe in the recovery sub folder with the one available here and try again: share.toradex.com/ufcdkiu5tfqdtm4

Yes, it is Win7. I copied the file and tried it out. Unfortunately no success.
Then I tried it with a Win 10 laptop. With that it worked. Now I have at least one way to get the Easy Installer running. This is ok for me at the moment. Thanks for your efforts.

Thanks for keeping us posted, glad it worked with Windows 10.

I had also the “claim interface failed” problem on Win7 Enterprise but only when USB was connected to docking station. USB directly connected to laptop did work.

Hi,

I have the same problem on my Win7 PC. Unfortunately, I don’t have any pc with other windows.

I have device with vid=0x1b67 pid=0x4fff visible in my device list. The imx_usb with delay didn’t helped, so maybe the delay is too short. Could you please add there a longer delay and/or some command line parameter support to run imx_usb.exe from that point where it can’t claim the interface at the first time? So I could make some ‘retry’ manually.

Does this have a solution for Windows 7? I have tried connecting through a USB 2.0 hub and get the same error as described in this thread for my Colibri iMX6 module.

@aaron.h,

Could you please try directly connect Colibri IMX6 to the PC without a hub and let us know If it solves the issue. Also, make sure iMX6 is in USB boot mode as described here.

@raja.tx,

I attempted a direct connection between the iMX6 and PC and still observed the “claim interface failed” message. I tried a second Windows 7 PC and it also could not restore easy installer on the SOM. I attempted the procedure with a Windows 10 PC and I was finally able to restore easy installer on the SOM. Is there a known Windows 7 configuration for recovering the SOM?

It seems to work on some hosts/configuration and on some not. Unfortunately we do not know exactly why it behaves differently on some hosts.