Do we've broken Dahlia?

Hi tech,

We’ve a dahlia carrier board rev 1.1. We use it to develop for mx8 devices.
It has been working fine for several months.

Today however we changed the network configuraton of a mx8 and then
everything frooze. We couldn’t access the mx8 anymore. We can’t even boot
or recover.
We exchanged the mx8 for another mx8, but: nothing.
So, we suspect there is a problem with the dahlia board.
So our questions:

  • is there a way to confirm that the dahlia is ok, eg: without a target device mounted?
  • is there a way to ‘hard-reset’ the board?
  • do you have other tips?

Kind regards,
Nacho

Hi @NachoXXL !

Could you please specify what kind of configuration you did?

You can check the test points that we have on Dahlia: connect it to power and check for hardware damage, according to its schematics (available at Dahlia Carrier Board | Toradex Developer Center).

Best regards,

Hi Henrique,

Thanks for the reply. I reconfigured the network by editting /var/lib/connman/ethernet_00142de0ed39_cable/settings
and changed it to this:

[ethernet_00142de0ed39_cable]
Name=Wired
AutoConnect=true
Modified=2023-06-09T11:03:01Z
IPv4.method=manual
IPv4.Addresses=192.168.0.78/24
IPv4.Gateway=192.168.0.1
IPv4.DNS=8.8.8.8
IPv4.DHCP.LastAddress=192.168.0.15
IPv6.method=auto
IPv6.privacy=disabled

(bold == changes or new)

Then I ran: systemctl restart connman

As a result it stopped working. I did not change anythin else, did
not even move the board.

Regards,
Nacho

Have you tried to collect a log from the serial debug UART?
The Dahlia Carrier Board features a built-in USB to Serial UART converter (FTDI FT4232HL), which can interface with the serial debug UART via the USB Type C connector X18.

If you change it back to auto IP I bet everything works.

Lease time.

You cannot change from auto to manual and use the last configured IP address. Off-the-shelf routers, especially for the home market, lease connections for at least 3 days once assigned.

Issue 2:

Unless you manually configured your router to reserve a certain range of IP addresses for fixed/manually configured addresses, it will not let you force an address of your choice into its table. You have to start all the way back at your router, manually block out a range of IP addresses from the Auto section, then manually assign one address to the Dahlia, then you can configure that address on your Dahlia.

Really old routers from the early 1990s would let you force in a fixed IP address if it wasn’t in use. That was a gaping security hole and hasn’t been allowed for decades.

Hi Alex,

Thanks for the reply. Yes I did. To be precise:

  • connect to board: sudo tio /dev/ttyUSB3
    → I get ‘connected’
  • push the power button:
    → nothing happens

Any ideas?
Regards,
Nacho

Hi @seasoned_geek

I understand the network point of view and I’d like to change the cfg,
however as the device does not start this is not a option.
I connect currently through tty so network problems are not an
issue currently.

Kind regards,
Nacho

Upon connecting the Dahlia board to your development machine via the X18 USB-C connector, you should observe the addition of multiple new TTY devices. The specific numbering of these devices will vary depending on your development machine’s configuration. Have you tried to test all of them?

If you sure if your Dahlia is broken you can start an RMA process using this form - Return Material Authorization (RMA)

Hi Alex/all,

Problem solved. It was an power issue. Somehow the source couldn’t handle
the device. Changed it, resetted the board and all seems fine now.
Sorry for the scare :wink:

Kind regards to all,
Nacho

Hi @NachoXXL ,
Thanks for the feedback. Glad that you could solve the problem :slight_smile:

Best regards,
Josep