Disable UARTA RTS in T30

Hello,

I’m using UARTA RTS as a GPIO with a relay, which gets activated when UARTA is used (at boot for instance). I don’t want to use RTS in any case, just TX/RX. I’ve tried disabling/setting as GMI the corresponding pinmux in board-colibri_t30-pinmux.c

//DEFAULT_PINMUX(ULPI_DATA3, UARTA, NORMAL, NORMAL, INPUT), 
DEFAULT_PINMUX(ULPI_DATA3, GMI, NORMAL, NORMAL, INPUT),

But it doesn’t make any difference.

Also, how can I enable the Quiet option at boot in Tegra?

Thanks,

Álvaro.

GMI pinmux for ULPI_DATA3 pingroup is incorrect, it is not possible to assign any random pinmux to a pingroup. See the possible pinmux options for ULPI_DATA3 here and in Section 4.4 of Colibri T30 datasheet.

You can try disabling the pinmux and then adding it here for using it as GPIO.

As @sanchayan.tx said, problem was setting ULPI_DATA3 as GMI. Changing it to HSI (as its pin group states) worked:

DEFAULT_PINMUX(ULPI_DATA3, HSI, NORMAL, NORMAL, INPUT),

No need to add it as GPIO. Funny thing is that with the GMI option it let me compile which I expected it shouldn’t. I guess since it actually exists (for other pins), it didn’t give me a compile error.

Thanks again!