Device Provisioning broken

i get the following error when trying to provision a device in torizon ota platform.

== Registering device (deviceID: apalis-imx8-067384XX) in system, and downloading credentials.

Failed to download token :(
{"exp":"token expired"}

Hi @nkj

Can you describe a bit how you managed to produce this error? I know the tokens will expire so if you waited a bit after pulling up the command to provision a device, it’s possible that the token is legitimately expired.


Hi @drew.tx

I went to website. clicked provision device and than copied and pasted it on the serial console. so was less than 5 seconds in terms of time interval.


If you refresh the window and get a new provisioning command, does it still fail?

hi @drew.tx yes. i have tried as well signing out of torizon platform and signing back in. i also tried registering two different boards but both give the same error. in the past this always seemed to work.

hi @drew.tx

i tried as well with a different internet connection and there as well not able to provision the device but getting a slightly different error

Failed to download token :(
{"name":"BAD_GATEWAY","description":"No resource or matching url pattern found to verify access.  Misconfigured gateway.","code":"502"}

Hi @nkj

The dev team found the root cause of your 502 error and have rolled out a fix. Can you recheck and confirm?

Also, can you check if the original issue still occurs?


Yes that seems to have fixed the problem. I was able to provision the device.