Date and time issue with VF61 and CE6

I’ve just found an issue while setting date and time for VF61 with CE6.

Maybe this can be related to this one.

It can be reproduced using Colibri VF61 mounted on Colibri Evaluation Board V3.2A following these steps:

  1. power on the module and look to the date and time in CE 6 menubar
  2. press the Reset button (not the On/Off)
  3. wait for reboot completion and verify that the date and time is correct
  4. Double click on the menubar to open the Date/Time Properties window
  5. change the date to whatever
  6. wait for a while and verify that the date is going on in the right way
  7. press the Reset button
  8. you can see that the date has re-started from 01/01/20006 12:00:00 PM

I don’t know if this makes difference, but on Evaluation board RTC_SEL jumper is set to EXT and the battery BAT1 is not present.

One more thing that can help finding the reason for the issue (and fixing it, I hope).

This problem happens only if RTCSync tool is disabled.

I disabled it as suggested by @andy.tx to fix this different problem.

Dear @vix

In the related post SetLocalTime reconfigures some GPIO I assumed you are not using any external RTC, because you were concerned that SetLocalTime() reconfigures pins which are connected to the external RTC.
For this reason I suggested to disable RtcSync.exe.

RtcSync.exe is required to …

  • load the external RTC’s time into the OS system clock at boot time, and
  • to write the time back to the external RTC whenever it has changed in the OS.

So without RtcSync.exe it is the expected behavior that you loose the time after a cold boot.


  1. Re-enable RtcSync.exe
  2. If required, let’s get back to the related issue SetLocalTime reconfigures some GPIO to discuss the actual problem behind the current behavior of RtcSync.exe, and how to fix it.

Regards, Andy

Hi @andy.tx

I confirm that I’m not using an external RTC neither on the Evaluation Board, nor on my custom board.

On my custom board I use SODIMM 194 and 196 as general purpose inputs connected to some custom hardware.

Dear @vix

If you are not using an external RTC connected to SODIMM 194/196, can you please point out what is your approach to keep the correct time over a power cycle?

Regards, Andy

Hi @andy.tx

on my custom board I use the internal RTC, and I have a 7.2V Li Ion battery that is always connected through a dedicated 3.3V LDO regulator to the Vrtc (SODIMM 40).

For this reason I think that disabling RTCSync driver is absolutely safe (and necessary, since I use SODIMM 194 and 196 for other purposes).

If I disable RTCSync driver I see that datetime is reset to 01/01/2006 12:00 PM when I try to change it (on my custom board).

Since I know that debugging problems on custom hardware is difficult for you, I searched a way to reproduce it with the Evaluation Board.

I found a way and I described it in the first message of this topic.

I hope that this answer clarifies a little bit the situation and helps in finding the solution.

Hi @vix

Now I understood the problem. We will need to do some analyses to find the root cause and solution. I will get back to you as soon as I have more information.

Regards, Andy


I have the same problem like vix described here.
My custom board have internal RTC and small backup 3.0V battery, I2C is connected to external temperature sensor.

When I turn off RTCSync.exe, date and time reset all the time.

Dear @vix, dear @KrisS

It appears that we broke the functionality for the internal RTC in image release V1.6b2, when we implemented the fix for issue #33179 (Time can only be set upto year 2034).

We will solve the problem with the next image release V1.6, which is planned for December 2018. Meanwhile I’m afraid the only solution is to downgrade to image V1.5


Hi @andy.tx

can you release a preliminary version of V1.6 so that I can check and confirm that everything is ok before the official release?

Dear @vix
Sure. We will send you the preliminary version for testing.
Regards, Andy

Can you provide a date for a prelimary release to test?
I can’t downgrade to V1.5 because I need the feature Backlight BL_ON signal at power-on doesn’t wait for stable pixel data

Dear @vix
You can expect the preliminary release within the next two weeks.
Regards, Andy

Hi @luka.tx

the preview image is a big step in the right direction, but it doesn’t fix the issue completely, unfortunately.

First of all, the exact name of the parameter in rtc is useinternal (and not useInternalRTC).
So the right command is

set rtc.useinternal 1
save rtc

But this is only important for documentation.

The problem is that after every poweron, the Time Zone is reset to “GMT-08:00) Pacific Time (US & Canada)”.
Date and time doesn’t change (and so they seems ok), but as soon as you change the Time Zone to the right one, date and time change accordingly (and so they become wrong).

Can you verify, please?

Dear @KrisSS
We will release an image soon, with this issue fixed. We always appreciate feedback whether our fixes work as expected.
Regards, Andy

I hadn’t tried before.
I followed your suggestion and if I save the registry everything is ok.

Is the TimeZone saved in the registry?

Yes timezone information is in registry.

I have the same problem with the update date on VF61 and eboot version 1.62
Are there any news?
Thank you

I have the same problem with the update date on VF61 and eboot version 1.62
Are there any news?
Thank you

HI @Matte

Issue was fixed and tested. Image is currently undergoing internal testing. I hope it will be available in 1 or 2 weeks.