'data send failed error' when trying to load loader.nb0 during flashing of WinCE7 to Colbri T30

I followed the instructions on the http://developer.toradex.com/knowledge-base/txx-recovery-mode page and everything worked great until I tried to flash the WinCE7 image using the update.bat file.

I have tried multiple times but I always get the same error. I used the latest image and recovery package. I also tried on multiple evaluation boards (iris and colibri). I’m trying to restore WinCE7 to a T30 module that suddenly stopped working.

The output is shown below.

Toradex NVFlash Update Script
*********************************** Nvflash version 2.1 started rcm
version 0X30001 System Information:
chip name: unknown chip id: 0x30
major: 1 minor: 3 chip sku: 0xb1
chip uid:
0x0000000000000000015d90cec028220b
macrovision: disabled hdcp: enabled
jtag: enabled sbk burned: false
dk burned: false boot device: emmc
operating mode: 3 device config
strap: 0 device config fuse: 0
sdram config strap: 0

Sending generated BCT…Done
downloading bootloader – load
address: 0x88300000 entry point:
0x88300000 sending file: loader.nb0
data send failed NvError 0x120002
command failure: bootloader download
failed (bad data)

Press any key to continue . . .

Any thoughts would be appreciated. Thanks.

There are two things I recommend you to check:

  1. Check if you are using the latest NVFlash Tool. You find the latest version online here.
  2. Also make sure you are using the updated version of the *.cfg files you have to provide during flashing the image. We have updated all the files also in older image download bundles. Please get the latest image package from here.