Custom Logo as SplashScreen at uboot

Hello ,
As per the requirement we are trying to include the custom splash-screen at U-boot and followed the below procedure but it didnt work for us. Let me know if i have missed something

1.created an .bmp image of size 640x480 of 8 bit depth using below command
convert testlogo.png -type Palette -colors 224 -depth 8 -compress none -verbose BMP3:testlogo.bmp
2.copied to this location “oecore/build/tmp/work/colibri_imx6-tdx-linux-gnueabi/u-boot-toradex/1_2020.07+gitAUTOINC+0401650db5-r0/git/tools/logos”
3.Compiled u-boot using “bitbake -f -c compile u-boot-toradex”
4.copied the output files ie SPL and u-boot.img to Toradex Easy Installer
5.Install the modified Toradex Easy Installer through usb0 using "boot_targets usb0 mmc1 mmc0 dhcp "
Logo was not displayed in the u-boot.

Note:we also tried coping the output files ie SPL and u-boot.img to Custom Image which was flashed using above Installer but this is also not working.

Toradex Easy Installer Version “colibri-imx6_toradexeasyinstaller_1.8-20181019”
Image Version Colibri-iMX6_Reference-Minimal-Image-Tezi_5.4.0
SOM Colibri IMX6DL

Was there a splash screen prior or nothing?

If nothing, you might have to enable the video stuff in your uboot defconfig. This page mentions that Splash Screen on U-Boot

1 Like

Hello DaveM
We have also enabled CONFIG_DM_VIDEO=y in the “oe-core/build/tmp/work/colibri_imx6-tdx-linux-gnueabi/u-boot-toradex/1_2020.07+gitAUTOINC+0401650db5-r0/git/configs/colibri_imx6_defconfig”. But it is not working.

I have attached defconfig for your reference.

colibri_imx6_defconfig (2.55 KB)

Hi @Gowthami

I could able to get the splash screen with the attached config options.colibri_imx6_defconfig (39.7 KB)

Hello @ashok.tx

Are you followed the same as above procedure ?

we tried all the resolutions but still it is not coming.Can you send me the image.bmp what you tried?

Hi @Gowthami

Yes,Followed the u-boot-splash-screen article and enabled CONFIG_DM_VIDEO=y ,CONFIG_VIDEO_IPUV3=y and CONFIG_CMD_BMP=y in u-boot defconfig and re-flashed.toradex.bmp (301.1 KB)

@ashok.tx
where you replaced the uboot files such as uboot.img and spl ?(Image or Installer)

Hi @Gowthami

Copied custom u-boot and SPL into the minimal image BSPv5.4 and reflashed with toradex easy installer v5.3

@ashok.tx
Doing the same still not working.

Hi @Gowthami

Attaching my u-boot and SPL file.check and let me know.SPL (43 KB)
u-boot.img (784.6 KB)

Hello @ashok.tx
I have tested the image with your u-boot files and it is working fine.

Hi @Gowthami

I have followed the same procedure mentioned Here and enabled CONFIG_DM_VIDEO=y ,CONFIG_VIDEO_IPUV3=y and CONFIG_CMD_BMP=y in u-boot defconfig.

@ashok.tx

Thank you for the reply.
We will test and update you.