Couldn't open watchdog : permission denied

Hello Toradex Community,

I want to use the watchdog that is native in the Toradex board.
But when I want to open it I get a “Permission denied” error.
Is there a way to change the permission of the file, situed here : “dev/verdin-watchdog”, permanently ?
I don’t want to change the permission of the file, through linux command, everytime my board is restarted.

Thank you for your support,

Regards,

Muzzy

Hello @Muzzy,

Thanks for reaching out. Could you please try and answer the following questions:

  1. What carrier board do you have?
  2. Are you using TorizonCore or BSP (Please mention with version)

Hello @rudhi.tx,

Thank you for your help,
I am currently using a Yavia dev board and I am using TorizonCore 6.0 version.
Regards,

Hi @Muzzy ,

you can try to change the permission in a udev rule.

For this you need to create a file like 99-watchdog.rules in the directory /etc/udev/rules.d.

In this file I added the line KERNEL=="watchdog", OWNER="torizon", GROUP="torizon". This changes the owner of the watchdog to the Torizon user.

If you want to be more specific you can see all the attributes of the verdin-watchdog by running udevadm info -a -n /dev/verdin-watchdog

Hope this helps.

Best Regards
Kevin

Hello @kevin.tx,

Thank you for your answer,
I’ve created the file you were talking about in your answer and it solved my “Permission denied” problem,
Thank you again for your help,

Muzzy

1 Like

Hi @Muzzy,

Thanks for confirming.

Glad that it worked!

Best Regards
Kevin