Container Python app - open a file - permission error

I’m new to the containers overall. I’m trying to open a new file in my python container to write data inside it. When I run the debug app, I have no issues - but when I try to deploy the container and then run it as a release (using the Torizon Extension in VSCode) I get a permission error when I try opening the file. Just looking at the dockerfile.debug and dockerfile.release created by the extension I can see that the debug file in its 3rd line has:


that the release file doesn’t have.
My guess is that the release version probably runs the application as root and not as torizon user, but I don’t wanna waste my time on some improvisational solution, I’m pretty sure there is a straight-forward solution for file permissions in containers that I just don’t know anything about.
Thanks in advance!

I think I found the solution under the developer pages, sorry for asking the question too early I really tried to exhaust the information on the website before asking the question, I just couldn’t find it for a long time.

I basicallly just mounted a new home/torizon/data folder under volumes in the VSCode extension and I’m saving my measurement data there. I will leave the question on the forum if someone stumbles on the same problem.

Good to see you were able to find a solution here.