Console-tdx-image un_pack error while build

ERROR: binutils-cross-arm-linaro-2.27-r2016.10 do_unpack: Function failed: base_do_unpack

ERROR: Logfile of failure stored in: /home/shiva/oe-core/build/tmp-glibc/work/x86_64-linux/binutils-cross-arm/linaro-2.27-r2016.10/temp/log.do_unpack.3035

ERROR: Task (/home/shiva/oe-core/build/…/layers/meta-linaro/meta-linaro-toolchain/recipes-devtools/binutils/binutils-cross_linaro-2.27.bb:do_unpack) failed with exit code ‘1’

and the build process fails.

if i do clean build and then if i start build again same error is coming.

how can i fix this ??

hi

Could you provide some information about your hardware and software.

Host PC:

  • Hardware
  • OS: ?

Which build are you doing?
OE??
Which branch are you compiling.

Provide also the hardware version of the toradex module you are using?

Best regards, Jaski

L Ubuntu 16.04 LTS

Pentium(R) Dual-Core CPU E5200 @ 2.50GHz

OE

http://git.toradex.com/toradex-bsp-platform.git -b LinuxImageV2.7

Apalis imx6q Evalution Board V1.1B

how did you start the build (which command …)? did you make any changes to the files before starting the build? If yes, please state the changes?

bitbake -k console-tdx-image

i have changed in local conf file.
i have added

DISTRO_FEATURES_remove = “x11 wayland”

IMAGE_INSTALL_remove = “eglinfo-x11”

ACCEPT_FSL_EULA = “1”

EXTRA_IMAGE_FEATURES += “read-only-rootfs”

and i continuous the build.

jaski,

below errors occured during build.
Can please explain why build fails through the errors.
i have tried to fix but we are unable.

ERROR: glib-2.0-native-1_2.52.3-r0 do_fetch: Fetcher failure for URL: ‘http://ftp.gnome.org/pub/GNOME/sources/glib/2.52/glib-2.52.3.tar.xz’. Unable to fetch URL from any source.

ERROR: glib-2.0-native-1_2.52.3-r0 do_fetch: Function failed: base_do_fetch
ERROR: Logfile of failure stored in: /home/shiva/oe-core/build/tmp-glibc/work/x86_64-linux/glib-2.0-native/1_2.52.3-r0/temp/log.do_fetch.5000

ERROR: Task (virtual:native:/home/shiva/oe-core/build/…/layers/openembedded-core/meta/recipes-core/glib-2.0/glib-2.0_2.52.3.bb:do_fetch) failed with exit code ‘1’

ERROR: linux-toradex-4.9-1.0.x+gitAUTOINC+1db9f06709-r0 do_unpack: Fetcher failure: Fetch command export DBUS_SESSION_BUS_ADDRESS=“unix:abstract=/tmp/dbus-3NVzKSmfCM”; export SSH_AUTH_SOCK="/run/user/1001/keyring/ssh"; export PATH="/home/shiva/oe-core/layers/openembedded-core/scripts:/home/shiva/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/linux-toradex/4.9-1.0.x+gitAUTOINC+1db9f06709-r0/recipe-sysroot-native/usr/bin/arm-angstrom-linux-gnueabi:/home/shiva/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/linux-toradex/4.9-1.0.x+gitAUTOINC+1db9f06709-r0/recipe-sysroot/usr/bin/crossscripts:/home/shiva/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/linux-toradex/4.9-1.0.x+gitAUTOINC+1db9f06709-r0/recipe-sysroot-native/usr/sbin:/home/shiva/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/linux-toradex/4.9-1.0.x+gitAUTOINC+1db9f06709-r0/recipe-sysroot-native/usr/bin:/home/shiva/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/linux-toradex/4.9-1.0.x+gitAUTOINC+1db9f06709-r0/recipe-sysroot-native/sbin:/home/shiva/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/linux-toradex/4.9-1.0.x+gitAUTOINC+1db9f06709-r0/recipe-sysroot-native/bin:/home/shiva/oe-core/layers/openembedded-core/bitbake/bin:/home/shiva/oe-core/build/tmp-glibc/hosttools"; export HOME="/home/shiva"; git -c core.fsyncobjectfiles=0 checkout -B toradex_4.9-1.0.x-imx 1db9f06709adfa8fbf538ebc0c17b0b29cf693c6 failed with exit code 128, output:
error: inflate: data stream error (incorrect data check)
error: failed to read delta base object 146f406b8f8a4dc25dbc248f4a8dce0dc5447f71 at offset 383352741 from /home/shiva/oe-core/build/downloads/git2/git.toradex.com.linux-toradex.git/objects/pack/pack-ef001512fcda2acafd6b61efb9c23e50a2213ac1.pack
error: failed to read delta base object f2d91f4028cace50888876ef28685c3eff2cb44d at offset 383355243 from /home/shiva/oe-core/build/downloads/git2/git.toradex.com.linux-toradex.git/objects/pack/pack-ef001512fcda2acafd6b61efb9c23e50a2213ac1.pack
error: failed to read delta base object 9f494b75848abc7514c53417a73e627454ba44ad at offset 383356130 from /home/shiva/oe-core/build/downloads/git2/git.toradex.com.linux-toradex.git/objects/pack/pack-ef001512fcda2acafd6b61efb9c23e50a2213ac1.pack
error: failed to read delta base object b1d7d9b0eb86e897ad0b11eb549bb23f11f74348 at offset 383356159 from /home/shiva/oe-core/build/downloads/git2/git.toradex.com.linux-toradex.git/objects/pack/pack-ef001512fcda2acafd6b61efb9c23e50a2213ac1.pack
error: failed to read object 96ae4f5bd0ebf5b905b1ca7ed9d4cd70c28c1fe2 at offset 383356201 from /home/shiva/oe-core/build/downloads/git2/git.toradex.com.linux-toradex.git/objects/pack/pack-ef001512fcda2acafd6b61efb9c23e50a2213ac1.pack
fatal: packed object 96ae4f5bd0ebf5b905b1ca7ed9d4cd70c28c1fe2 (stored in /home/shiva/oe-core/build/downloads/git2/git.toradex.com.linux-toradex.git/objects/pack/pack-ef001512fcda2acafd6b61efb9c23e50a2213ac1.pack) is corrupt

ERROR: linux-toradex-4.9-1.0.x+gitAUTOINC+1db9f06709-r0 do_unpack: Function failed: base_do_unpack
ERROR: Logfile of failure stored in: /home/shiva/oe-core/build/tmp-glibc/work/apalis_imx6-angstrom-linux-gnueabi/linux-toradex/4.9-1.0.x+gitAUTOINC+1db9f06709-r0/temp/log.do_unpack.6350
ERROR: Task (/home/shiva/oe-core/build/…/layers/meta-toradex-nxp/recipes-kernel/linux/linux-toradex_4.9-1.0.x.bb:do_unpack) failed with exit code ‘1’

i want to know where is the problem ?
please do help.
almost from last four weeks we are facing these problems.

my pc details are…

LUBUNTU 16.04 LTS 64bit

Architecture: x86_64

CPU op-mode(s): 32-bit, 64-bit

Byte Order: Little Endian

CPU(s): 2

Model name: Pentium(R) Dual-Core CPU E5200 @ 2.50GHz

Internet:

Upload speed is 6 mbps

Download speed is 6 mbps

RAM - 2GB

Hard disk - 100GB free space

Please check ABOVE requirements is sufficient for building or not?

If not suggest me requirements.

its urgent
reply ASAP.

Hi
are you able to access this file?

manually i can download it.
but in building its showing unable to fetch error

please check above post once

please suggest reply

are you behind a proxy server?

Can you please check above post message.
i have written my machine details.
those requirements is sufficient or not?

are you behind a proxy server?
No

Just get yourself a decent build machine.