Connman crashes on start with "Aborting (signal 11)"

I have an Apalis i.MX8 on an Ixora V1.1A which I flashed with both BSP 5.4 via Easy Installer. The ethernet connection doesn’t come up. When I investigated the problem through the serial console, I noticed that the connman service fails to start. Starting it manually shows more details. Did anyone else encounter this error?

I tried downgrading to BSP 5.3 and get the same error:

root@apalis-imx8:~# systemctl status connman
* connman.service - Connection service
     Loaded: loaded (/lib/systemd/system/connman.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Thu 2021-10-07 13:33:46 UTC; 2s ago
    Process: 2165 ExecStart=/usr/sbin/connmand -n (code=exited, status=1/FAILURE)
   Main PID: 2165 (code=exited, status=1/FAILURE)

Oct 07 13:33:46 apalis-imx8 systemd[1]: connman.service: Scheduled restart job, restart counter is at 5.
Oct 07 13:33:46 apalis-imx8 systemd[1]: Stopped Connection service.
Oct 07 13:33:46 apalis-imx8 systemd[1]: connman.service: Start request repeated too quickly.
Oct 07 13:33:46 apalis-imx8 systemd[1]: connman.service: Failed with result 'exit-code'.
Oct 07 13:33:46 apalis-imx8 systemd[1]: Failed to start Connection service.
root@apalis-imx8:~# /usr/sbin/connmand -n
connmand[2220]: Connection Manager version 1.37
connmand[2220]: Checking loopback interface settings
connmand[2220]: System hostname is apalis-imx8
connmand[2220]: lo {newlink} index 1 address 00:00:00:00:00:00 mtu 65536
connmand[2220]: lo {newlink} index 1 operstate 0 <UNKNOWN>
connmand[2220]: eth0 {create} index 2 type 1 <ETHER>
connmand[2220]: eth0 {RX} 65 packets 8860 bytes
connmand[2220]: eth0 {TX} 99 packets 19892 bytes
connmand[2220]: eth0 {update} flags 102467 <UP,RUNNING,LOWER_UP>
connmand[2220]: eth0 {newlink} index 2 address 00:14:2D:63:EB:D7 mtu 1500
connmand[2220]: eth0 {newlink} index 2 operstate 6 <UP>
connmand[2220]: Adding interface eth0 [ ethernet ]
connmand[2220]: can0 {newlink} index 3 address 00:00:00:00:00:00 mtu 16
connmand[2220]: can0 {newlink} index 3 operstate 2 <DOWN>
connmand[2220]: Aborting (signal 11) [/usr/sbin/connmand]
connmand[2220]: ++++++++ backtrace ++++++++
connmand[2220]: #0  0xffff8bd2d5b8 in linux-vdso.so.1
connmand[2220]: #1  0xaaaac095dc2c in /usr/sbin/connmand
connmand[2220]: #2  0xffff8bc167bc in /usr/lib/libglib-2.0.so.0
connmand[2220]: #3  0xffff8bc16b68 in /usr/lib/libglib-2.0.so.0
connmand[2220]: #4  0xffff8bc16ebc in /usr/lib/libglib-2.0.so.0
connmand[2220]: #5  0xaaaac095aa0c in /usr/sbin/connmand
connmand[2220]: #6  0xffff8b7dd110 in /lib/libc.so.6
connmand[2220]: +++++++++++++++++++++++++++
root@apalis-imx8:~#

Edit: After building the BSP 5.4 image myself and flashing via easy installer, the network works perfectly fine.

Hello @jeker ,

Welcome to Toradex Community!
Does this mean the issue is solved for now?

Best regards,
Janani