Connecting to WiFi timeout error

Hi, I’m using the wifi module iMX6ULL with the provided Linux LXDE image and I’m trying to connect to my wifi, but I’m getting some errors:

connmanctl> agent on
Agent registered
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
        Guests              wifi_<HASH>_managed_psk
connmanctl> connect wifi_<HASH>_managed_psk
Agent RequestInput wifi_<HASH>_managed_psk
    Passphrase = [ Type=psk, Requirement=mandatory ]
Passphrase? 12345    

and after some time I get the result:

Error /net/connman/service/wifi_<HASH>_managed_psk: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

What am I doing wrong?I’ve tested with different wifi, even with my mobile router.

hi @lcasagrande

Could you provide the software version of your module?
Please share the dmesg log in a file and also the details about your Wifi Router (Hardware, Software, Encryption, …)?

Best regards,
Jaski

I’ve used the Easy Installer to flash the image on module. The dmesg log is attached. And I’ve tested on default Android wifi router, it should not block the module connection.

dmesg log

Regards,

Luccas

Hi,
the dmesg log looks fine.

And I’ve tested on default Android wifi router, it should not block the module connection.
Could you provide some more details of your router?

I could get this information about my local access point:
Model: UniFi AP-AC-LR
Encrypt: wpapsk

I’ve noticed that I was trying to connect using uap0 interface. But now using mlan0 I’m getting another error:

connmanctl> connect wifi_<HASH>_managed_psk
Agent ReportError wifi_<HASH>_managed_psk connect-failed
Agent request cancelled by ConnMan
Error /net/connman/services/wifi_<HASH>_managed_psk: Operation aborted

yes, mlan0 is the interface for the wireless client.

Could you share the output of journalctl after this error occurs?
Additionally try to use a simple passphrase for the connection to the router.

Best regards,
Jaski

I’ll try to use simple passphrase. The journalctl log is attached.

journalctl.log

Regards,
Luccas

Thanks. Let us know if it worked with a simple passphrase. What changes have you done to the software?

@jaski.tx Thanks for your attention!

I’ve discovered the problem. The WiFi antenna wasn’t properly connected, so the wifi signal was to low. Connecting correctly solved the connection problem… Frustrating… haha

Thank you again for your support! You guys are the best!

Best regards,

Luccas

Perfect, that it is solved. Thanks for the feedback.