Conmanctl not working on apalis imx6

We used conmanctl to set static IP till now on all our production Apalis IMX6 boards. We have had no issues till date.

But we have come across some boards where conmanctl is not working. The IP address of the board is changing on every reboot.

On investigation we have come across that the /var/lib/connman has multiple entries of the driver as opposed to one.

Kindly suggest a possible solution at the earliest as an production is on hold.

Thanks and Regards,

Margaret Dsouza

Hi @MargaretDsouza

Welcome to Toradex community.

Could you provide the hardware and software versions of your setup? also provide the steps to reproduce the issue.
Are you using a custom Linux BSP?Have you tried systemd?

Hi Ashok,
Kindly find the responses below

Linux BSP version 2.7.3
Apalis iMX66Q 2GB
Ixora V1.1A

Steps to reproduce the issue:

  1. Use connmanctl to set static IP
  2. Reboot the board
  3. The static IP is changed

We have tried using systemd also

Hi @MargaretDsouza

I quickly checked with my setup (Apalis imx6Q+ixora) and the Linux version BSP v2.7.4.I could able to set the static IP and it is not changing even after multiple reboots.

#connmanctl config ethernet_00142d4a2a16_cable --ipv4 manual 192.168.10.5 255.255.255.0 192.168.10.254

#connmanctl config ethernet_00142d4a2a16_cable --nameservers 8.8.8.8

Note: The image version which you are using is outdated and is no more supported.