Colibri VF61 Audio Recording problem -- Amplitude


I am working with multiple Colibri VF61 with Linux 2.7b2 and iris carrier board, to record audio. Whilst most of them are working as expected, one of the colibri is presenting an odd behavior. For some reason that I cannot figure out, the amplitude of the output signal is much smaller than from the other Colibri. (I have 5, and only one of them is presenting this behaviour).

I am recording via only the left line pin in the iris, and setting ALSA mixer with the following command:

amixer set 'Capture Mux' 'LINE_IN'

Though other configurations also present the same behavior.

I am recording with the following record configuration in a script:

arecord -q -r 48000 -f S16_LE -c 1 -t wav -d 30 "recording.wav"

Below is an image of the problem (image taken using Audacity):

Note the difference between the two images. the first one is what I expect, and the result obtaining by the other 4 Colibris. The one below is from the Colibri presenting the strange behavior.

I am using the same Linux image for all of them, same Iris, same power source, same signal, same scripts, same pen-drive, same hydrophone, same gain (default gain)… same everything. Worth noting that the colibris were inside a case to help isolate some noise from the environment.

I had this problem once before, Though I am not sure it was this same module. I resolved it by formatting everything. But it doesn’t seem right to me that this problem will occur randomly.

I have executed a plethora of tests trying to figure out what is the problem, but no luck. Could it be a problem with this specific colibri vf61? All I want is to get approximately the same signal output from all of them.

Any help would be appreciated. Thank you in advance.

We are not aware of such amplitude differences. To rule out software I would make sure that really all amixer settings are the same (e.g. diff the output of amixer output). Beside the Mic volume there is also a Capture Boost mixer setting which can make a difference:

amixer set 'Capture Boost' unmute

Otherwise can you provide the module version and serial number of a working and of the module showing the issue?