Colibri_vf_defconfig is not in the kernel source. How to compile kernel for colibri vf61?

Can’t find default configuration “arch/arm/configs/colibri_vf_defconfig”!

One need to select appropriate git branch specific to platform and release Image. Find the relevant information in this article.

Did you follow the instructions as per here? What is the current branch? Can you provide the output of

git branch -a

Is the setup as per this subtopic?

I already followed the article you mentioned and I am using toradex_vf_4.4 branch but still getting the error. For which branch, I will not get this error?

Can’t find default configuration
“arch/arm/configs/colibri_vf_defconfig”!

Can you share the output of

git branch -a

and also make sure to setup toolchain.

osboxes@osboxes:~/linux-toradex$ git branch -a
* toradex_vf_4.4
  remotes/origin/colibri
  remotes/origin/colibri_vf
  remotes/origin/tegra
  remotes/origin/tegra-next
  remotes/origin/toradex_imx6
  remotes/origin/toradex_imx_3.10.17_1.0.0_ga
  remotes/origin/toradex_imx_3.10.17_1.0.0_ga-next
  remotes/origin/toradex_imx_3.14.28_1.0.0_ga
  remotes/origin/toradex_imx_3.14.28_1.0.0_ga-next
  remotes/origin/toradex_imx_3.14.52_1.1.0_ga
  remotes/origin/toradex_imx_3.14.52_1.1.0_ga-next
  remotes/origin/toradex_imx_4.1.15_1.0.0_ga
  remotes/origin/toradex_imx_4.1.15_1.0.0_ga-next
  remotes/origin/toradex_tk1_l4t_r21.5
  remotes/origin/toradex_tk1_l4t_r21.5-next
  remotes/origin/toradex_vf_3.18
  remotes/origin/toradex_vf_3.18-next
  remotes/origin/toradex_vf_4.0
  remotes/origin/toradex_vf_4.0-next
  remotes/origin/toradex_vf_4.1
  remotes/origin/toradex_vf_4.1-next
  remotes/origin/toradex_vf_4.4
  remotes/origin/toradex_vf_4.4-next

And I already setup a gcc-linero toolchain as defined in doc.