Colibri T20 USB doesn't work


I have a new Colibri T20 module which I mounted on the Toradex evaluation board and our own platform but on either it doesn’t connect to any PC/laptop through the USB.
Sometimes it says USB drive is not recognised and sometimes nothing.
I tried adding the dwords in registry setting as well but no difference.
Could you please tell me what I should do ?


Can you please let us know what version of the OS are you using?

Windows CE 6.0

@shivaeghbal: Do you see this issue only with this module or with others as well?

With 3 different T20 modules so far.

Could it be you are using an olde evaltuation board (2.1 or older)? These boards do not support highspeedd USB, which are set by default. You can either patch the board or set the USB port to fullspeed only. Find more details here:

We have the Evaluation board V2.1c.
It did work with PXA270 and does run Win CE6 for T20 on a monitor connected via VGA cable. Just the USB is not working to let us deploy the exe file on it.
Also we have made a platform for T20 that the USB worked but now on those modules that don’t work on the evaluation board they don’t work on the platform as well.
I am looking at the link you sent me, but it seems that the issue is something else.

@shiva_eghbal: This really sounds like the USB highspeed / fullspeed issue.Please either modify the registry as descirbed above, the USB keyboard should work as it is running in fullspeed only.

If this still does not solve the issue, please try once our standard image to make sure it is not a custom image issue.