Colibri iMX8DX: display artifacts when using GPU

We want to upgrade our current system from an Colibri iMX7D to a more powerfull Colibri iMX8DX. With the iMX7D, everything works as expected.

For a first test I have build the tdx-reference-multimedia-image and added the customized device tree for our display.

The built image boots, shows the framebuffer console and starts the test application Qt5_CinematicExperience. As soon als the video starts playing, the image is heavily disturbed. When I start glmark2-es2-wayland, the display also flickers.
When I switch to a framebuffer console, the flickering stops immediatly. Also, when only the desktop or a weston-terminal is running, the display does not show any disturbances.

For reference, I also tested with the prebuilt Torizon, that starts chromium. Chromium also shows the artifacts.

Any hints, what the problem could be?

Here is a link to a video, showing the display artifacts: (18 MB)

Module: Colibri iMX8DX 1GB WB V1.0D
Carrier: own design
Display: Riverdi RVT50UQTNWC0x (5", 800x480, RGB interface)

Yocto BSP5
Distro: txd-xwayland
Image: tdx-reference-multimedia-image
Application: Qt5_CinematicExperience (from reference image)

Hi @steff ,

Thanks for the information.

We will try to reproduce the issue and update you with new information as soon as its available.

Best Regards

Hi @steff ,

For your information, the issue had been escalated internally and our team is working on it.

Would it be possible for you to do a further test on your end?

It might be possible that this is caused by an EMC issue. To confirm that could you try to move the display cable physically away from the PCB?

Does the behaviour change in any way after you do that?

Best Regards

Hi @kevin.tx,

I already considered EMC and tried to move the cable further away. I also added a shielding foil around the cable and the CPU module. There is no change in any way to the behaviour.

Since the RGB interface has a voltage swing of 3.3V, the EMI has to be rather large, to cause an error. From the image distortion, the affected signal must be the clock or the hsync signal. I mesuered both signals but could not see any problems with the signal quality.

From this I currently assume, the signals are already distorted, when leaving the module.

On monday, I hope I will get hands on a second module and see, if the problem is the same.

BR, Stephan

Hi @kevin.tx,

the other module does not show those artifacts. It seems, the first module has a hardware defect. :slightly_frowning_face:

BR, Stephan

Hi @steff ,

Could you please confirm that the “other” module is the same version as the “not-working” one?
I assume both are Colibri iMX8X’s.

If so you might be onto something here.

Best Regards

Hi @kevin.tx,
both modules where ordered (and deliveired) together. Besides the serial number, the print is identical. I attached images from both modules.

not working:


BR, Stephan

Hi @steff !

Could you please create an RMA request for the non-working module? We want to investigate this issue.

Best regards,

@henrique.tx on its way :slight_smile:

1 Like

Hi @steff ,

we received the module.

We will update you as soon as we have something new.

Best Regards

1 Like

Was this something you could identify? I am having the exact same issue, this time on a 1280x800 display running on an Iris v2.

Is there any chance that this can be solved with a newer BSP? Looking at it seems to be software-related, and all the SoMs we tested it with (4 of them).

Hi @lisandropm ,

Thanks for letting us know. We are still investigating.

At this point I would like to ask you a couple of questions:

  • What BSP are you using on your end?
  • Does this behaviour appear on every boot? Or does it disappear after a reboot?
  • Could you run the command systemctl stop wayland-app-launch.service and check if the flickering stops after that?

If the flickering stops after this please try the following.

  • Add or modify this file /etc/xdg/weston/weston.ini with this variable use-g2d=0

And let us know what happened.

Best Regards

Excellent :smiley:

I am at commit fbdee6b9362eafd23f8f3aea90f4174b5061e150 of Index of /toradex-manifest.git, a little after tag 5.7.1.

It happens on every boot. I could not avoid it in any way.

root@colibri-imx8x-07203010:~# systemctl stop wayland-app-launch.service
Failed to stop wayland-app-launch.service: Unit wayland-app-launch.service not loaded.

It didn’t, I tried non the less and the result is the same.

Ditto :smiley:

I am considering trying BSP 6, even if it has not been released for this SoM… except you tell me not to :slight_smile:

Maybe worth to mention: if the image becomes still then the problem dissapears.