Colibri IMX7 PingPong example issue

Hi all,

I try to run the pingpong example (binary file from the wiki, and from the master-1.0.1 branch). I followed the instructions but I still have some issues.
I can load and run a binary file like hello_world.bin.
But when I run bootaux with the pingpong example, the M4 just prints the two first lines of the following :

    RPMSG String Echo Demo...
    RPMSG Init as Remote
    init M4 as REMOTE

Moreover I didn’t find any printf of the 3rd line in the source code .

After a look on the code, I found out the programm gets blocked on env_acquire_sync_lock() function, which waits for taking a mutex.

I guess it can be linked with the following command line in the colibri-imx7

    # modprobe imx_rpmsg_pingpong

It doesn’t print anything, because imx_rpmsg_pingpong is already in the kernel.
I tried to remove it from the kernel and to add it again, with the same result.

Finally, I restored the module and it is now working. I don’t really understand what was wrong. It must have been an internal issue.

Hm, I guess by restoring you installed the V2.6 Beta 2 Linux BSP version? Could it be that you were using an older release before?

Anyway, glad it works now.

No,I didn’t change the version. I used the same software each time.
That’s why it still is a mystery to me. Joy of embedded software I guess.