Cog issues with select and slider components


We are using the latest kiosk container based on Cog, in combination with a touchscreen. It seems impossible to use a select or slider component with this browser. Sliders work if you just point to at the position you want it to be at, but dragging doesn’t work. For selects, you have to be very lucky to get the list of options to show, but then it is almost impossible to select an item from it. Are these known issues with Cog? I did some touchscreen tests using touch results and that website is responding to touch events as expected.


Hi @mvandenabeele, how are you?

  • Can you please confirm which TorizonCore version and Verdin Module you’re using?
  • Also, which carrier board do you have?
  • Are you using any Toradex screen?
  • If not did you update the right overlays for the touch screen you’re using?

Also, do you have any examples of websites where you face this problem? We did a quick test with the slider on the following site: and it seemed to work from our side.

Best regards,

I made a little demonstration page on our company website:

We’re using a 2GB Verdin on a custom carrier with a custom display and touchscreen. OS version info:

verdin-imx8mm-07219448:~$ cat /etc/os-release
VERSION=“5.7.0-devel-20220712135651+build.0 (dunfell)”
PRETTY_NAME=“TorizonCore 5.7.0-devel-20220712135651+build.0 (dunfell)”

The touchscreen is working fine on the touchscreen test website I mentioned in the opening post.

I did some further testing. I used the Chromium kiosk and the select and slider input do work. This rules out my web application code and the touch driver, leaving only Cog. I can’t switch to Chromium because that introduces other issues which would take an equal amount of time to fix on our side.

Hi @mvandenabeele, how are you?

We’ve been able to reproduce this behaviour with an Apalis iMX6 running Cog. Therefore, this is probably related to the container itself. We opened an internal ticket for investigation and we’ll come back to it soon.

Best reards,

Hi @gclaudino.tx

Any news on this issue?

Hi @mvandenabeele, how are you?

We’re still investigating this issue on our side to find the root cause and understand if this is a problem with COG or with something that we made for this container.

Have you tried to see if this behaviour also happens on your side with another Display such as an HDMI connected?

Best regards,

I did not use another display because the module is on a custom carrier board and there’s no HDMI output on it. I did some tests with Chromium on the same device and the sliders were okay. That rules out the hardware I think. Chromium had performance issues so we can’t switch to that. I hope you can find a solution soon!


Hi @mvandenabeele !

We have some news on this issue.

I was able to reproduce the same issues with the slider and with the popup/dropdown menu on Reference Multimedia Image from BSP 5.7.0 with Cog 0.12.0 (from this exact commit: GitHub - Igalia/meta-webkit at ba3c5c6d15109dc8d8b48c865c94424c526dcbfa) on Verdin iMX8MM DL 1GB V1.1A + Dahlia V1.1C + LVDS 10.1” V1.0A from Toradex.

Researching this, I found this Popup menu not opened when selecting HTML select element · Issue #503 · Igalia/cog · GitHub issue on Cog’s repository and created the following patch:

From b7dfd571307ebb0a2fbeef7cb1b8b79b54b117a3 Mon Sep 17 00:00:00 2001
From: "henrique.garcia" <>
Date: Thu, 6 Oct 2022 15:25:24 -0300
Subject: [PATCH] Fix popup on Wayland

According to
 platform/wayland/cog-platform-wl.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/platform/wayland/cog-platform-wl.c b/platform/wayland/cog-platform-wl.c
index f62faad..9279b16 100644
--- a/platform/wayland/cog-platform-wl.c
+++ b/platform/wayland/cog-platform-wl.c
@@ -2272,7 +2272,7 @@ create_popup (WebKitOptionMenu *option_menu)
         xdg_popup_add_listener (popup_data.xdg_popup,
-        xdg_popup_grab (popup_data.xdg_popup,, wl_data.event_serial);
+        //xdg_popup_grab (popup_data.xdg_popup,, wl_data.event_serial);
         wl_surface_commit (popup_data.wl_surface);
     } else if ( != NULL) {
         popup_data.shell_surface = wl_shell_get_shell_surface (,

After applying, rebuilding, and testing using your, the popup was fixed: Reference Multimedia Image (BSP 5.7.9) with Cog 0.12.0 patched for popup menu - YouTube

Therefore, this is really an issue with Cog and not with its container or with the OS/BSP.

As the slider issue is still happening, to fix that we recommend you get in touch with Igalia.

Best regards,

Hi @mvandenabeele !

Do you have any news on this topic? Were you able to test the patch above?

If possible, could you share what will be your approach on this?

Best regards,

Hi @mvandenabeele,

Do you have any news on this issue?

We did more investigation into this issue and probably there is an error in how Cog handles touchscreen calls from Wayland. We tested the same scenario with our BSP 5.7.1 using Cog 0.8.1 from the meta-webkit layer dunfell branch and it works.
Cog 0.8.1 uses x11 as the default platform, so probably that’s why it’s happening with this version.
Unfortunately, I tried the same with TorizonCore installing Cog 0.8.1 inside a container and it didn’t work. TorizonCore uses Weston/Wayland as compositor.

I’ve opened a ticket inside their repository and found more tickets related to this issue. Please, check them below:

I’ll take a look if we can overcome this problem somehow, but most probably we will have to wait until Igalia developers solve this bug.

Best Regards,

Hi @mvandenabeele !

Do you have updates on this topic?

Best regards,