Capacitive touch display 7" parallel touch is not working with vf50

I connected the capacitive touch 7" parallel display and adapter with viola carrier board pins as described in the touch adapter datasheet. Display is working fine but touch is not working. I already installed setup driver in the VF50 for wince6.
Please guide for any correction or additional steps to make touch working for the setup.

Dear @Mania

Did you connect the touch signals through the Capacitive Touch Adapter as described on the First Steps page?

If you you used your own adapter to connect the touch signals, please send me a picture and/or a description of the connections, so I could verify if you did it correctly.

Best Regards

Dear @andy.tx

alt text

This is the type of connection I did and the Touch adapter is from toradex.

alt text

Dear @Mania
The connection looks fine. I’m asking for some additional information so I am able to reproduce the problem:

  • Which OS (including release version) are you using?
    START → Programs → ColibriTools → UpdateTool → [Version Info]
  • Can you point me to the exact download link for the driver you used?
    How did you install the driver?
  • Did you verify that there are pull-up resistors connected to the SDA and SCL signals (5kΩ or lower)?
  • Please enable the debug output and send me the log messages that are output during the system boot.

Regards, Andy

Dear @andy.tx,

  1. Using OS version 1.3 (CE 6.0)
    2) link from where I downloaded the driver.
  2. I connected 1k Ohm pull-up resistors to the SDA & SCL signals.
    4)I attached a screen which comes when I run the I2C demo Application.
    Please let me know any mistake.
    Thanks & Regards,

Dear @Mania,

Thank you for your patience and debugging details.

Could you please let us know, is there any reason the purpose of using v1.3 release image on Vybrid module?
If there are no reasons, please update to v1.5 and then try to do same?

Please follow below procedure to update v1.5,

  • Update OS Image using update tool v7.5.0 which is on v1.5 standard release image inbuilt.
  • Update Eboot using the same update tool
  • Clear Registry
  • Reboot and verify v1.5 image is launching.

Dear @Mania,

This issue might be related to Could you please try the suggestion from that thread and let us know if you face any difficulty on that.

If it doesn’t work, Please enable the debug output and send me the log messages that are output during the system boot and accessing touch.

Dear @raja.tx,

Your suggested thread is for linux system and I am using Wince.

Dear @Mania,

Of course, Linux application will not work on WinCE. You need to program Linux on Vybrid module and try that thread. Once the configuration is programmed and it will be persistent and then you can reprogram WinCE on Vybrid module.

Please let me know from which country shop you bought the display?

Dear @andy,

It worked, the issue was with the int & reset pin number in the registry.

Dear @raja.tx ,
I already tried v1.5 wince6 and v1.5 wince7, but touch is still not working.