Capacitive Touch Display 10.1" turns black after short time


I have an Apalis iMX8Q, Ixora Carrier Board V1.2A and your 10.1" Touch Display.
And installed the TorizonCore with evaluation containers on it. Guided by your Quickstartguide.

I also configured the /sysroot/boot/ostree/torizon-*/dtb/overlays.txt with

fdt_overlays=apalis-imx8_lvds_overlay.dtbo apalis-imx8_atmel-mxt_overlay.dtbo display-lt170410_overlay.dtbo

And see the device:

$ find /sys/devices -name "edid"



If I start now the system the Display will show shortly some bootup lines. Then it feels like it stocks. And after that the Display will get partial darker until nothing is shown.
If I reboot immidiately the display will be black all the time. If a wait a while until maybe parts are cooled down I have the first behaviour.

Looks something takes too much current. Do you have an idea what I should configure? Or are any Jumpers wrong on my carrier board?

Thanks for any help.

That is my system:

$ cat /etc/os-release



VERSION="5.1.0+build.1 (dunfell)"


PRETTY_NAME="TorizonCore 5.1.0+build.1 (dunfell)"



Greetings @runner,

I can say for sure this is not a known issue. Other than applying the overlays (which it seems you did correctly) there shouldn’t be any other configuration required. It does sound like somewhat of a hardware issue possibly, since the kernel seems to think there’s an LVDS display connected.

Can you check the system’s dmesg and check if there’s possibly any issues related to displays/LVDS there?

Additionally what kind of power supply do you have connected to the Ixora carrier board? The LVDS connector is directly connected to the power input connector. For this reason, use only 12V (+/-10%) power supplies with the board. Otherwise, you can damage the LVDS display or observe a malfunction.

I’ll also check with our hardware team if there’s anything else that can be checked here.

Best Regards,

Hi Jeremias,

In the meantime I’m not anymore convinced with my overcurrent theory. Furhermore it’s to say that it was never possible to use the HDMI port too. I used always the VNC alternative.

Here is my dmesg output:
dmesg output

The dmesg output does show various errors, but some of them seem irrelevant to me. Can you check please the dmesg output for me?

The power supply I have connected running the dmesg with was the one from Toradex Carrier Board Accessory Kit. Before I used a labor powersupply which I set to 12V and 2.6A current limit.
At the beginning I run the carrier board and SOM also with a 24V supply, but I never had connected then the Touch Display to it.

Best Regards

Wait HDMI never worked for you as well? Even in Easy Installer? What happens if you swap the overlays for HDMI instead of LVDS as shown here: Device Tree Overlays (Linux) | Toradex Developer Center

Just to narrow possible issues do you have any other Toradex carrier boards/modules that you can try? I’m starting to think it may be hardware issues/damage with this specific hardware you have.

Best Regards,

Hi @jeremias.tx,

Yes HDMI was working never, even in Easy Installer.

I did that swapping already in a remote session together with @kevin.tx without success. May he could give you some more information.

I have only the colibri equipment here. But this is very different to the Apalis family. From Apalis I have only one equipment.

Did you see something interesting in the dmesg output I attached before?

Best Regards

Hi @runner ,

I just tested using the same setup as yours (same module - but version V1.1B -, carrier board, and same LVDS display).

The HDMI monitor I used on TEZI (V2.06b, pre-installed on the module) wasn’t working for TorizonCore 5.1. But I changed the HDMI monitor and I could get image. So, maybe, there is some issue regarding the HDMI communication with the monitor.

After enabling the same overlays as you (but using TorizonCore-Builder for it), the LVDS started working along with the HDMI display (Portainer on HDMI monitor).

If I remove the HDMI overlay, I get, as expected, only the LVDS display showing the Portainer on Kiosk mode browser.

Best Regards,

After some internal discussion there’s reason to believe that possibly either your carrier/module have some kind of hardware damage/issue. Rather than try to debug this any further, it might be more timely to just issue an RMA on the hardware and get you new hardware to work with.

Please submit an RMA request: Return Material Authorization (RMA)

Best Regards,

I got today a HDMI-to-HDMI cable and now the “HDMI-monitor” works. Before I tried it with a HDMI-to-VDI cable.

Nevertheless the Touch Display isn’t working. I will think about the RMA but for my first tests the HDMI monitor will do the job.

Interesting seems like then it was a cabling issue. I don’t believe we explicitly test HDMI to DVI cables but I guess this can cause communication issues.

But anyways glad to hear HDMI is now working for you. Keep us updated if anything else happens with regards to the LVDS. But for the time being I guess we can consider this issue “resolved” since you’re unblocked with your initial testing.

Best Regards,