Can't set GPIO config using ConfigBlockEditor in batch mode on iMX6

I can successfully use the ConfigBlockEditor in batch mode to change the serial port settings and the splashscreen settings. But it doesn’t seem to work for me in batch made when I try to change the GPIO settings. If I use the ConfigBlockEditor interactively with a mouse and keyboard then changes I make to the GPIO pins are saved and are applied when I reboot the module.

I’m trying to follow the example for the iMX6 on this page:

I’ve tried this batch file which matches the example on the web page:
set pin.71.ctrl=1
set pin.71.direction=1
set pin.71.strenght=4
set pin.71.level=1
save pin

And also this one:
setconfig pin.71.ctrl 1
setconfig pin.71.direction 1
setconfig pin.71.strenght 4
setconfig pin.71.level 1
saveconfig pin

The ConfigBlockEditor runs the batch files without reporting any error, but the configuration is not changed. I am using WinCE image 1.8 on a Colibri iMX6D with v1.13 of the ConfigBlockEditor.

I downloaded v1.13 of the ConfigBlockEditor, although confusingly it shows “V1.11” when I run it as shown below. I tried a few of the older versions and noticed that most of them seem to show a different version when running than the name of the file which was downloaded. Is it possible that I’m not really using v1.13?

This question is quite similar to this other question from a few years ago. But the answer to that other question doesn’t seem relevant.

Could you please specify HW revision of your Colibri iMX6 module, OS (WEC7/WEC2013) and its BSP version?

I’ve tested this ConfigBlockEditor on WEC7 BSP v1.18. Batch mode works as expected. Pleas see attached example of config file.
Settings.TXT (124 Bytes)

Thanks @alex.tx, that helped me to figure it out as your batch file does work. I tested a few variations and learned a couple of things:

  1. Using “set pin.71” does not work in the batch file, it needs to be “setconfig pin.71”
    The example for iMX6 on this page uses “set pin.71” but I realize now that example must be for the bootloader command prompt and not the ConfigBlockEditor batch file.
    GPIO config block settings | Toradex Developer Center

  2. The example batch file I posted had a spelling error! It used “strenght” instead of “strength”
    That makes the ConfigBlockEditor stop processing the batch file at that line but it doesn’t report an error. The spelling of “strenght” came from copying and posting from the page referenced above, you might want to fix that page. I don’t actually want to set the pull-up anyway, I just added that to follow the example to try to get it to work.

  3. Your batch file does change the configuration that appears in the ConfigBlockEditor but the change has no impact at boot time because you didn’t add setconfig pin.71.ctrl=1. If I add that line then the settings are applied by the bootloader.

Thanks for your help with this one, I’m all set now.