Can't run qt5.6 example on wec2013 (imx6)


I have compiled qt 5.6-beta with VS2015 for WEC2013 and I’m just trying to run the simple example:

qml ../examples/animation/animation.qml

and it aborts withe unable to load QT5Qml.dll

Using a “Hello World” - MFC example and loading the qt-libraries with

HINSTANCE instance = LoadLibraryW(".dll")

and checking the debug-in vs2015 did not help:
loading Qt5Core.dll aborts with an

Exception thrown at 0x428EDC63 (Qt5Core.dll) in Application1.exe: 0xC0000005: Access violation writing location 0x00000012.

excption. Qt5Gui, Qt5Qml and Qt5Widgets just don’t load at all.

I tried to add the lib…dll into the bin directory aswell as the msvcr/msvcp - but nothing helped.

Here is my configure line:

configure -v -platform win32-msvc2015 -xplatform wince80Toradex-armv7-msvc2015 -rtti -mp -ltcg -release -opensource -confirm-license -no-compile-examples -nomake tests -no-opengl -openvg -skip qtandroidextras -skip qtactiveqt -skip qtsensors -prefix %CD%\SDK

Any help is greatly appreciated.


If system says “unable to load QT5Qml.dll” it normally means that some depended library is missing. Hence I am assuming that your deployment to the target is not correct. Please also be aware that you might need the c++ runtime for the platform to copy. You can use the tool called dependency walker for the desktop to find out dependencies even for WEC2013. Also its recommended to use the windeployqt, you can find the documentation on deployment here.

For the MFC part its most likely also a dependency issue but also not the quite common case to load Qt in a MFC application, hence normally just done for migration projects or a mixed application, but which is more complicated.

Hope this helps a bit.


thanks a lot for your answer!

I was able to start our application using windeployqt and installing it ion the flashdisk.

Sofar I couldn’t test the qml-example, but this is not so improtant right now.

The application didn’t start from the SD-Card. This might be solved, when we switch to the 1.1-beta BSP

Thanks again!



just a confirmation. After switching to the wec2013 V1.1b2 image, the qml example just runs fine.

kind regards