Can't run CameraDemo source code

Can’t run CameraDemo source code , by VisualStudio 2013.

I follow the instructions.

But i have this problem

“Visual Studio needs to make non-functional changes to this project in order to enable the project to open in Visual Studio 2013, Visual Studio 2012, and Visual Studio 2010 SP1 without impacting project behavior.”

project can not be loaded. How to fix it?

Dear @konstantin,

We have updated the VS property files recently, that may solve this issue. Please download the VS property files from here and overwrite it on the library root directory and then try to open the project in the Visual Studio 2013.

Still, if you see the similar error then you would need to convert a project from Vs2015 to VS2013. As you know, there are many visual studio versions Microsoft released and providing many project files would not nice release and time-consuming process.

Please let us know if you have any questions on this.

With this property files i run aplication successfully. But i can’t see image from camera, i see black screen
instead image. In demo version aplication, no such problem.

Dear @konstantin,

Which WinCE release version you are using? Could you try the previous version of release image and let us know the result e.g. v2.1.

I am using WinCE 2013 ver 2.1. When I have installed ver2.2, any application couldn’t be started.


  1. screenshot when i run camerademo_wec2013.
  2. screenshot when i run source code(CameraTegra project), a see black screen instead image from camera. [upload|SMAsdWFMPYWwcSEfoEHR9kCZG3w=]

Dear @konstantin,

Could you log the debug messages and share with us through the link here) or attachement feature. Also attach complete source code with built binary. Let me try to debug the issue with your application project settings and binary.

link text

debug messages

Dear @konstantin,

There are many debug prints differences on your log.
Could you share the complete source code project with built binary and let me try to debug with that. Which camera sensor are you using?

You can upload the project to our file transfer platform and post the link here, you want to get there.


I am using ADV7280 sensor. I did not do any changes in sourse code, just run code with you property files and have this problem.

Dear @konstantin,

Sorry for a delayed response. I am looking into this. Could you please wait for a couple of days.

Dear @konstantin,

Thank you for your patience. We are able to reproduce the issue on v2.2 release and seeing another issue in v2.1, WEC2013 but it works on v2.1, WEC7. If you would like something to start to develop then you would consider using v2.1, WEC7 and continue your development. Meanwhile, we will work on the v2.2 bug and get back you once it is solved. We don’t need to consider v2.1, WEC2013 bug I guess eventually it will be solved if we solve the v2.2 bug.

We would like to know how long would you wait for the solution.

Now I’m going to start developing applications on Linux. I would like to develop both on WinCE and Linux, so I’m wating for you fix the bug on WinCE2013. I encountered the same problem when i run projects with usb, mipi camera, in usb camera I can record video and play it, but i cant see real time video(black screen).

Let me know when the bug is fixed. Thank you.

Dear @konstantin,

Thank you for your reply. We will get back to you once it is solved maybe after a few weeks or a couple of months.

Dear @konstantin,

We would like to check your progress on this task. When do you expect a solution from us for WEC2013, v2.2 bug, this will help us to schedule the task in a better way.

Thank you.

Now I developing on Linux. WinCE is not so relevant now. I will continue development on WinCe as soon as you can fix bugs.