Can't read partition table on 1:0

Dear community,
I tried to perform flashing of Colibri iMX6 module with no success.

Once inserted SD card, I sent the command “run setupdate” from U-Boot prompt but the partition is is not recognized correctly.

Colibri iMX6 # run setupdate
** Can’t read partition table on 1:0 **
** Invalid partition 1 **

Do you have any idea on the cause of the problem?

Thank you

Hi

I’ve sometimes see such error messages when changing SD cards when U-Boot is running.
Do you have the same error when you insert the SD card and power cycle?

Does you’re SD card have a strange partitioning? E.g. when you boot the Colibri iMX6 to Linux where does the card get mounted and the installation files are visible on /media/mmcblk1p1?
What is the output of mount | grep mmcblk1

Max

Hi Max,
thank you for your help.

I confirm that message is a bit different if I power cycle with SD inserted (see below)

*Colibri iMX6 # run setupdate
** Invalid partition 1 ***

After boot the card get mounted on /media/mmcblk1

The output of “mount | grep mmcblk1” is

colibri-imx6:~# mount | grep mmcblk1
/dev/mmcblk1 on /media/mmcblk1 type vfat (rw,relatime,gid=6,fmask=0007,dmask=00)

Regards

Max,
Problem solved with new SD partitioning.

I noticed that the SD was mounted on mmcblk1 instead of mmcblk1p1.

Thank you.