Can't get the clock to come up with NTP synchronization set to true

I modify by device with the timedatectl set-ntp true and working. I run the isolate command and put that in my changes directory. I run the union command to put it in the build. However, after the final combine command, and install, the clock ntp sychronization is not set.

Steve

1 Like

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


Hello,

It seems like you’re encountering an issue where NTP synchronization settings are not persisting after applying changes and rebuilding your system. When you use timedatectl set-ntp true, it should enable the NTP synchronization, allowing your system clock to automatically synchronize with network time servers.

The issue might be related to how the changes are captured and applied in your build process. Here are a few steps to troubleshoot and ensure the NTP synchronization setting persists:

  1. Verify Current NTP Status: Before proceeding with the isolation and union commands in your build process, verify the NTP status with timedatectl status to ensure it’s enabled (NTP synchronized: yes).

  2. Check for Systemd Services: Ensure that systemd-timesyncd service is enabled and running. You can check this with systemctl status systemd-timesyncd. If it’s not active, enable it with systemctl enable systemd-timesyncd and start it with systemctl start systemd-timesyncd.

  3. Configuration Persistence: Depending on your build system, changes made with timedatectl might not persist through a rebuild unless specifically captured. Ensure that your build process includes steps to capture system configuration changes, such as NTP settings. This might involve modifying configuration files directly related to systemd-timesyncd or ensuring that the filesystem state is correctly captured and applied.

  4. Review Build Process: Re-examine the steps involved in your build process—particularly the isolate, union, and combine commands you mentioned. It’s crucial to ensure that these steps correctly capture and apply system settings. If these commands are part of a custom build system or script, ensure they’re designed to handle system configuration files correctly.

  5. Manual Configuration File Check: As a workaround, you can manually ensure that NTP is enabled by editing the configuration file for systemd-timesyncd directly, typically found at /etc/systemd/timesyncd.conf. Ensure that the NTP= line is uncommented and correctly configured. After making changes, restart the systemd-timesyncd service.

If after following these steps, NTP synchronization still fails to persist, it might be necessary to delve deeper into the specifics of your build and deployment process to identify where the configuration loss occurs.

Best regards,
Toradex AI Assistant

Please, also check if these links can help you solve your problem:

Real-Time Clock / RTC (Linux) | Toradex Developer Center.

Have you resolved this issue? If not, please provide a detailed description of what you have done so far, including step-by-step instructions and the exact commands you used.