Can't flash uboot Colibri iMX6 in recovery mode


I have been using iMX6S modules using linux for a while now and never had a problem until now. I was flashing a fresh image made with yocto and everything was OK, made “run update” and began to flash everything, last line was “resetting …” which was weird because the board resets itself after that line.
I powercycled the board but never got uboot to load.

Then I followed the instructions to enter recovery mode, and flashed an official Toradex linux image (V2.6), the output was similar: “resetting …” but can’t get to load uboot. I even flashed uboot only (run update_uboot) but never got uboot to load afterwards.

Can this be a hardware problem?

Hardware used:

Col iMX6s IT V1.0B

Iris Rev 1.1

12V PC (ATX) Power Supply … I’m blaming this because was the only thing I changed from previous setups.

Thanks for your help.


  • what is the output of “fuse sense 0 5” entered on the U-Boot cmdline started from recovery mode?
  • does the module boot when you load U-Boot over recovery mode and then enter ‘boot’ from the U-Boot cmdline?
  • assuming you can boot Linux that way, what is the output of “cat /sys/devices/soc0/soc.0/2100000.aips-bus/2198000.usdhc/mmc_host/mmc0/mmc0:0001/boot_info”
  • does the module boot when you press the reset button?
  • do you remember what version of our BSP you were based on before this happend?


Thanks for your reply Max,

I also tried using eboot in recovery and flash WinCE but the result was the same. Then I changed the uSD card and it worked, so apparently it was a damaged uSD card that was causing some troubles. I’m sorry I can’t answer all your questions now since it is working right.

Thanks again.