Cannot load into toradex easy installer

Hello,
I have a Verdin IMX8M using a Yavia board. I have plugged in all the cables like shown in the quick start guide. However, when i power on the board there is only a banana loading screen that shows up. Afterwards, nothing just a pure black lighted up screen (I’ve waited for 1hours and its still black). I tried everything, using HDMI 2, plugin the USB C cable to the DRP port. Nothing worked. So i tried reinstalling the Toradex easy installer but my board cannot go into recovery mode apparently since even if I hold the recovery button for 100seconds the output of lsusb doesn’t change. I’m using PopOS by the way but I also tried it on Windows 11 and yeah no difference.
Has anyone got a solution to this ?? I have been having this problem for like two weeks and its starting to drive me insane.

Here is my cable setup :


Here is the weird banana loading screen I’m getting :
And here is the black lighted up screen I get afterwards :

Thank you very much,
Matthias.

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


Hello Matthias,

It seems like your Verdin iMX8M module is not booting into the Toradex Easy Installer as expected. The banana screen you mentioned is not a part of the standard boot process for Toradex modules, indicating that the module is not entering the recovery mode correctly or the Easy Installer is not being loaded properly.

Given your description, let’s ensure the steps to enter recovery mode are correctly followed for the Verdin iMX8M on a Yavia carrier board:

  1. Ensure the module is powered off before starting the process. Disconnect the power supply to be sure.

  2. Press and hold the Recovery button (B3) on the Yavia carrier board. This is crucial and needs to be done before and during the application of power to the board.

  3. While holding the Recovery button, connect the USB Type-C to Type-A cable into the DRP connector (J7) and the other end to your PC. This step is for loading the Easy Installer.

  4. Plug the power supply cable into the J1 connector on the Yavia board to power on the board. Continue to hold the Recovery button (B3).

  5. Keep the Recovery button pressed for about 6 seconds after applying power, then release it. This timing is critical to ensure the module enters recovery mode.

  6. Check the lsusb output on your Pop!_OS or Windows system. You should see a new device indicating that the module is in recovery mode. If not, there might be an issue with the recovery process or the connection to your PC.

If you’ve followed these steps accurately and the lsusb output still does not change, consider these additional troubleshooting steps:

  • Try a different USB cable and port: Sometimes, the issue might be as simple as a faulty USB cable or a port that does not support the data connection properly.

  • Check for any visible damage on the USB-C port on the Yavia board or the USB ports on your PC.

  • Monitor serial console output: If possible, connect a serial console to the Verdin module to check for any boot messages. This might provide clues on where the boot process is halting.

  • Ensure no peripherals are causing issues: Disconnect any non-essential peripherals from the carrier board during the recovery process. This includes HDMI, USB devices, etc., to rule out any interference.

If after these steps your module still does not enter recovery mode, there might be a

Please, also check if these links can help you solve your problem:

Loading Toradex Easy Installer | Toradex Developer Center.

It looks like your Verdin module has been flashed with a different OS image. You can get more information about the flashed image by analyzing the boot log from the serial debug console available on the Yavia USB Type-C connector J5. I recommend loading (and then flashing) the Toradex Easy Installer through USB OTG as described here. This will return the module to its factory state.

1 Like

Thank you for your response,
I tried loading the toradex easy installer through the USB OTG interface however the recovery script wasn’t able to detect the device both on windows and PopOS. Furthermore, I don’t even think i was able to get it to go to recovery mode. As I said i tried booting the device up into recovery mode but the output of lsusb didn’t changed.

As for the serial debug console. I’m unable to identify the device port number. On windows no COMX port appear when i plug in the device and on PopOS no ttyUSB*, tty*, ttyACM*, ttyS* appears.

The module seems to be working tho. My router is giving it an IP and when I ping that IP it anwsers successfully. However I can’t connect to VNC to it both using Vinagre and TightVNC as it just refuses the connection.

Cheers,
Matthias.

Hello @Matthias_24,
You should be able to see serial port devices coming up on your linux machine when connecting a cable to J5 on the Yavia. Are you sure this cable you’re using is a data cable? It looks like it’s a cable for charging a device, maybe it doesn’t have the data lines connected:

The same goes for the recovery port. Additionally, I had issues loading the recovery software when my cable was connected to a specific hub in my setup while other hubs worked just fine.

Best regards,
Rafael

1 Like

Well I guess you were right.
I ended up buying a new USB-C to USB-A cable and it worked the first try so I guess that was that. I would have never thought they manufactured cables without the data lanes in.
Thank you very much,
Matthias.

Hello @Matthias_24, I’m glad it worked! Thank you for your feedback.