Cannot enter recovery mode on Apalis iMX6 with Ixora board

Hello,

I just got an Apalis iMX6 with Ixora dev board.
First I installed an embedded Linux OS on it from the Toradex options.
But afterwards I discovered that I want to install a different OS on the device

I tried entering recovery mode by shortening the pins on the board as described in the Toradex website but it doesn’t work.
I removed the JP2 connector, connected the board to the PC, shortened the wires and powered the board on. Waited more than 6 seconds and when I restart the device afterwards it still loads the OS that I previously installed.

Is there something that I am missing or a different way to flash a new OS on the device?

Hello @Svetoslav ,

After you have entered the recovery mode (by shorting the pins and powering on the module ) do not reboot the module. Doing so will result in a normal boot.

Instead, connect the USB cable from the PC to the OTG port of the board, and in the PC start the recovery script that you can download here:

After that the module will reboot and you will be able to connect to it via VNC and install another OS.

Best regards,
Josep

Thank you for your fast response.
That worked.

1 Like