Can i use Python-twisted with Colibri VF61?

What are some Python modules are supported by VF61. Flask, twisted , pyqt?

Assuming Linux, the python flask and twisted modules can be installed with opkg as these are available in Angstrom as well as our Toradex feeds.

opkg update
opkg install python-stringold
opkg install python-netserver
opkg install python-twisted

Flask has dependencies on quite a few modules one of them being werkzeug. While werkzeug can be installed with opkg that particular version installable with opkg is old and seems to give a different problem.

Install flask with opkg

opkg install python-flask

and then install pip with

opkg install python-pip

Using pip now install a few other python modules which flask requires.

pip install werkzeug
pip install jinja2
pip install itsdangerous

twisted and flask should now be usable.

# python
Python 2.7.9 (default, Mar 15 2016, 15:40:05)
[GCC 5.2.1 20151005] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import twisted
>>> import flask
>>>

python-pyqt is not available in the feeds and would require building through OpenEmbedded. Please refer the following article for OpenEmbedded setup.

I installed python-twisted
but simple “import twisted” in program is saying no module twisted.

Which image version are you using? The python twisted module has dependencies on python-stringold and python-netserver. Doing the following

opkg install python-stringold

opkg install python-netserver

opkg install python-twisted

and then

root@colibri-vf:~# python
Python 2.7.9 (default, Sep 30 2015, 12:09:35) 
[GCC 4.9.3 20150311 (prerelease)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import twisted
>>> 

I tested this on Colibri VF61 with the latest image.

I am using GCC 4.8.3. its not working on GCC 4.8.3. My python version is 2.7.3.

Which image version are you using? What is the result of

cat /etc/version

on the module? What all commands did you execute with opkg?

Angstrom v2014.06

Please try with a recent up to date v2.5 Beta2 or v2.5 Beta3 image.

@koustubhavachat, did installing the packages mentioned above resolve your problem? If not, which Toradex BSP/image version are you using? Check cat /etc/issue to get the image release date.

I am using Colibri_VF_LinuxImageV2.3_20141031. I will change it to 2.5_20151216 given in http://developer1.toradex.com/files/toradex-dev/uploads/media/Colibri/Linux/Images/