By Using Update Tool to Update OS image on Colibri T20 Fail

I was trying to update my OS image on Colibri T20. SystemInfo

Update Tool showed successful message and popped up a confirm dialog to let me restart my device.

However, restarting was fail with black screen. No response from device.

I’m not sure I operated it correct. My updating steps are as below :

  1. Download CE7 image from here
  2. Copy nk_ce7.nb0 to SD Card.
  3. Plugin SD Card to board.
  4. Execute Update Tool on WinCE.
  5. Click Update button in Bootloader/Image section.
  6. Click restart after updating process finished.
  7. Black screen

I was confused about the functionality of Update.exe and UpdateTool.exe after watching demo video of Update Tool.

If I want to update my OS image, should I follow the demo video? or the readme.txt in zip file of Toradex built OS image?

Please give me some advises for

  1. How to fix my device and OS image.
  2. How to update custom OS image by using Update Tool.


Hi @Jill,

I understand that you try to update only the Image (nk_ce7.nb0).
did you start with 2.3? (like the the screenshot)
what version of the Image did you download? (2.3?)

could it be that the nk_ce7.nb0 file is corrupt? (maybe the SD Card is not ok?)

You say after the update there is no output on the screen, but since you did not touch the Bootloader that one should still be OK and produce some initial display output.

Also can you try to check the serial debug output? maybe there is something there.

To restore the module, just use the USB recovery procedure:

@germano.tx, thanks for your tips.

I did try to update my OS image from 2.3 to 2.3.

I just wanted to test the functionality of UpdateTool first to make sure this way works.

So that, later I can do what I actually wanted to do - update custom OS image.

The OS of my computer is Windows 10.

SD card is workable on my computer and was formatted before I used it.

But there’s error message on the module when I tried to write files to SD card. (Read files is ok.)

Not sure if it’s the reason that caused updating fail.

I will try to check the serial debug output and restore the module first.

Later I would try updating image again by the steps described in readme.txt of image zip file.

If there’s any incorrect action, please give me some advises.

Thank you!

Hi @Jill,

I heard from another customer that there might be an issue with some SD Cards. I’m investigating that. Can you try to do the update from a USB Stick instead?

Or can you try the workaround described here:

Hi @germano.tx

The workaround you provided for SD Card works perfectly! Thank you.

I have another question that I encountered before the OS image of the module was broken. The connection between my development PC and the module through USB cable is not working.

I have seen this article and disabled ActiveSync Connection. But it remains the same.

Is there any other settings I should do before connecting them? My PC didn’t show any message or install driver when I connected them by a USB to USB cable. I tried micro USB to USB cable too. Both are not workable. Do you have any ideas about it?

Hi @Jill,

I guess you’re using Windows 10 on your PC… so it’s a bit complicated to make it work there as MS did not care about compatibility anymore…
First of all ActiveSync was replace by Mobile Device Center on the PC side…
But because of some Windows 10 updates the functionality was completely broken some years ago…

you can read this on how to fix it:


Actually, I have another wince device that works. (Not Toradex module) The Windows Mobile Device Center was activated once I connected the device with USB cable.

But the module - T20 that I used did not response. I’ve tried to fix the USB communication by following the article, but still not working. Do I need to set the registry or something to solve this issue?

Another issue, I’ve tried to enter recovery mode by hardware mechanism. But I was still not able to see the module as APX device. So if I’d like to reset the whole module, is there any article that can be reference?


Dear @Jill,

It’s very strange that even recovery mode does not work.
Maybe there is a USB issue on the carrier board you’re using. Which one you use? Colibri Evaluation board?
Maybe the USB_DET Jumper is missing or not contacting properly?

Hi @germano.tx

I’ve recovered my core board - T20 by using Colibri Evaluation Board to enter recovery mode, put it back to my customized carrier board. Everything’s fine.
Then I also built and updated OS image with drivers that I need. But OS shows normal with Colibri Evaluation Board, not with my customized carrier board.
OS image V2.3 <— Both carrier boards are OK.
Custom Built OS image ← Colibri Evaluation Board OK, the other one FAIL.

I think there’s some differences of build options. Could you tell me how to set those options?

Hi @Jill ,

I’m not sure what you changed from out default Workspace. The best thing would be to compare our original pbxml workspace file with your modified one. The settings you show are only a very little part of what you can customize.

Also to narrow down the problem it would be helpful if you elaborate on what is failing with your custom build image on your HW. can you send me the serial debug output? So i can see where the boot process stops.

Here is how to enable serial debug output: