Build workspace including USBSER driver for WEC7

I’d like to build a workspace containing Prolific USB serial converter driver “USBSER.dll”.
“USBSER.dll” needs to be placed in \Windows\System.
Add the following to OSDesign.bib, but it will be placed in \Windows.

MODULES
  USBSER.dll     $(_FLATRELEASEDIR)\USBSER.dll     NK SH

What else do I need to put in the right place?

Why do you need to place it inside System?

If you want to load it on boot placing it inside Windows is probably the way to go.

Dear luka.tx

Thank you for response.

I was able to solve this problem on my own.

When installing using the cab file of the downloaded driver,
I had to set the path to “\FlashDIsk\System”.

Even when building a workspace, it did not work well when “USBSER.dll” was placed in “\Windows”. This is the same problem as installing with cab file and I thought that it was necessary to set the path to “\System”.

However, I noticed that there is a registry “HKLM\Loader\SystemPath”.
Since “\FlashDisk\System” is set by default, adding “\Windows” successfully recognized the driver.

Dear luka.tx

Thank you for response.

I was able to solve this problem on my own.

When installing using the cab file of the downloaded driver,
I had to set the path to “\FlashDIsk\System”.

Even when building a workspace, it did not work well when “USBSER.dll” was placed in “\Windows”. This is the same problem as installing with cab file and I thought that it was necessary to set the path to “\System”.

However, I noticed that there is a registry “HKLM\Loader\SystemPath”.
Since “\FlashDisk\System” is set by default, adding “\Windows” successfully recognized the driver.