[Bug] Building custom torizoncore improperly generating torizon-core-docker-verdin-imx8mp.ota.tar.zst

I just built a new TorizonCore image for the Verdin system and when I went to install it with the Easy Installer, it complained that it couldnt find the file:


Inspecting the generated tar from the build directory (torizon-core-docker-verdin-imx8mp-Tezi_5.7.1-devel-20221215192943+build.0.tar) I see that file, but without the ota.tar.zst extension.

Manually modifying that file to include that file extension, it then installs the image just fine.

I did try rebuilding a few times to see if it was a fluke but it happens everytime.

Here are my exact steps I did (windows containerized setup)

docker run --rm -it --name=crops -v ${HOME}:/workdir --workdir=/workdir -e MACHINE=verdin-imx8mp -e IMAGE=torizon-core-docker torizon/crops:dunfell-5.x.y startup-tdx.sh

cd /workdir/torizon
vi ./build-torizon/conf/local.conf

// Add configuration changes

cd /workdir/torizon
bitbake torizon-core-docker

Greetings @joejankowiak,

I just did a build myself to double-check this. For me the file had the proper extension attached. That is to say I can’t seem to reproduce this myself. Also on our internal automated builds, this file with the extension seems to be generated properly as well.

This sounds somewhat similar to this other thread here: Torizon-core-docker-apalis-imx8.ota.tar.zst gets truncated

Though the user in this thread never really figured out what the original problem was.

Best Regards,

Hi Jeramias,

Sorry for the late response, I forgot about this. Seems like this is an issue that even happens to your nightly builds.

I just downloaded “torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4” from your website, and when I tried to install it it complained about no ota.tar.zst. Looking at the extracted folder it generated a file with the name “torizon-core-docker-verdin-imx8mp_”.

I’m using 7zip to extract it on Windows, and maybe thats causing an issue if you think its getting packaged correctly. In 7zip, it seems like it ends in a “.” but extracting it changes it to an “_” but doesn’t look like theres the file extension in either.

Forget what I just said. I did some more testing and it 100% is an issue with 7zip…

Windows now supports tar directly in cmd. Using that it extract it with the full filename where as 7zip truncated it

C:\Users\joe.jankowiak\Desktop>tar -xvf torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4.tar
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/toradexlinux.png
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/marketing.tar
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/prepare.sh
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/wrapup.sh
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/LA_OPT_NXP_SW.html
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/image.json
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/torizon-core-docker-verdin-imx8mp.ota.tar.zst
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/u-boot-initial-env-sd
x torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4/imx-boot

Maybe it would be good to add a note to the documentation warning that 7zip can cause issues with that file since 7zip is such a popular tool?

I’m glad you were able to resolve your issue. That said I don’t know if 7zip is the sole cause/issue here. I use 7zip on Windows as well and have never had issues with filenames being truncated.

In fact I just tried using 7zip to unpack “torizon-core-docker-verdin-imx8mp-Tezi_6.1.0-devel-202212+build.4” as well and all file names are intact on my side.

Best Regards,