Bootloader menu issues after custom settings

I entered successfully in the bootloader menu for months pressing [SPACE] in a serial terminal.

I’m sure the serial port works properly because I see the expected outputs from other modules.

Some weeks ago I modified some bootloader parameters based on my needs.

Following this KB I disabled the bootloader output. As expected, I don’t see anything on UART_A but I can enter the bootloader pressing [SPACE].

First issue: I can’t restore the original behavior if I set boot.silent to 0.

Second issue: In this scenario the VFxx Recovery mode doesn’t work (on Colibri Evaluation Board 3.2). I tried both “uboot over eboot” and “eboot over eboot”, but none of them worked.

How can I configure the bootloader to print information on UART_A again?

Some weeks ago I set my custom splashscreen image (fullscreen).

Third issue: It seems that after this configuration, I can’t enter the bootloader anymore (pressing [SPACE]).

The behavior seems similar to this one for iMX7 but I can’t use EasyInstaller (which worked in that case).

I have an update on First issue.

It seems that the reason is in the parameter ser.port which has been somehow set to 0.

Based on this KB, valid values for VF61 are from 1 to 4.

set ser.port = 1 fixed the issue of bootloader information not visible on UART_A.

Is it possible that set boot.silent = 1 changes ser.port to 0 too?

Set port 0 and 1 is the same.

If I remember correctly recovery mode does not check config block so you should be able to enter bootloader.

Based on your answer, there could be some unexpected side effect somewhere.

I confirm that set ser.port = 0 doesn’t send any bootloader information to UART_A.

On the other side, set ser.port = 1 sends bootloader information to UART_A.

hmm I do not have code here but I will check this in the morning. Maybe I remember wrong

I want to write something since I was able to fix the issues and maybe this can help other users.

Second issue (VFxx Recovery Mode not working) came from a misunderstanding of the documentation.

I suggest Toradex to add some information at the end of section Run recovery utility >> Windows (more or less what it’s written at the end of Linux section). As an example (my suggestion):

This downloads E-Boot to the modules memory and starts it from there.

DO NOT REBOOT the module.

On the same serial connection a serial console should appear after downloading the boot loader, with the message

Press [SPACE] to enter boot console.

For the steps required to completely restore the system as soon as the boot loader is running on the target, refer to the OS-specific articles in our knowledge base.

As soon the bootloader is downloaded through Recovery mode, both first and third issues can be fixed.
Both first and third issues are related to the bootloader parameter ser.port.

I don’t know what set it to 0 (I think to set boot.silent = 1, but it’s only an idea).

It’s necessary to enter the command set ser.port = 1.

In this way the bootloader sends messages on UART_A and it’s possible entering the bootloader pressing [SPACE].

what happens if you set ser.port to 0 or 1? Do you still get output on same port? ( not in recovery mode but normal ) I do see in code this should be the same.

Hi @luka.tx

did you have a chance to look into this issue?

I checked on my end and setting port to 0 or 1 does the same thing. Did you maybe change something else also?

Did someone review my suggestion to improve the documentation in the KB (as described in my message above)?