Boot failed Apalis imx6 when turned on, but starts normally after a reset

We have an Apalis iMX6Q 1GB V1.1Bmodule that does not boot when the power is turned on, it writes the following error to the serial terminal:
spl: mmc partition switch failed
SPL: failed to boot from all boot devices
ERROR ### Please RESET the board ###

However, after a reset, it always starts normally and works perfectly. I have tried several times to recover, reinstall, but it does not change the situation. This is a new module, used for the first time. We are using multiple modules, we only experienced this error for this one.
What can cause this error?
Bootloader version: Toradex Bootloader 1.4 for iMX6 Built Dec 13 2018, we use WEC2013 operating system.

Have you tried latest BSP (v1.6)?

Yes, I tried. The issue is same.

Hi @vigh.balazs ,

The issue you see looks like something we also saw on some other iMX6 modules and we are currently investigating. So far we saw this behavior only at higher temperatures (>70°C), but the output you get is exactly the same. It seems like an issue with RAM initialization. Something need a bit longer to stabilize (maybe a voltage) and that’s why it works after a reset.
As the issue is in the SPL (pre-bootloader) and this is maintained by the Linux team i cannot do much, but i should get a test version of the new SPL in a few day so you can test if it solves the issue.

Hi @vigh.balazs,

Sorry that it took so long. I finally have the new SPL that should solve the boot issue you see.
It’s very important that you update both the bootloader (eboot.spl) and the SPL file itself. The new bootloader is essentially the standard 1.7 bootloader, but with some additional header fields that are needed by the new SPL. If you don’t update the bootloader the system won’t boot at all as the SPL will consider the old bootloader as invalid.

Here is the download link:

Let me think if it help for your issue.