Bitbake tdx-reference-multimedia-image getting struck at 74% for apalis imx8

Hi Team,

I’m trying to build tdx-reference-multimedia-image for “apalis imx8”, build always getting struck at 74% and some time at 94%.

But I’m able to build tdx-reference-minimal-image successfully without any problem.

Attached snaps of build process.

Laptop setup details:

  1. Bootable linux machine with Ubuntu version – Ubuntu 20.04.4 LTS
  2. Referred link : Build a Reference Image with Yocto Project/OpenEmbedded | Toradex Developer Center
  3. Python version – Python 3.8.10
  4. Build/conf/local.conf - MACHINE ?= “apalis-im8” and ACCEPT_FSL_EULA = “1”
  5. Run - $ bitbake tdx-reference-multimedia-image

Laptop system configuration :

  1. RAM 32 GB
  2. Hard disk 1 TB

Since I have reference many links from toradex community , it doesn’t work for me.
Kindly suggest to build successfully complete for tdx-reference-multimedia-image

Hi @djewargi

Have you tried adding PARALLEL_MAKE = “-j 10” and BB_NUMBER_THREADS = “12” in the local.conf?if not, try and let me now.

Hi Ashok,

Thanks, It’s working fine after addition of PARALLEL_MAKE = “-j 10” and BB_NUMBER_THREADS = “12” in the local.conf

Deepak Jewargi

Hi @djewargi

Glad it worked.Thanks for the update.