,Bitbake do_rootfs failed with Rocko and dev-pkgs in EXTRA_IMAGE_FEATURES

Hello,

I try to build the angstrom-lxde-image from the LinuxImageV2.8 branch (Tag: Colibri-iMX6_LXDE-Image_2.8b1.64-20171229). I added in local.conf the following EXTRA_IMAGE_FEATURES:
EXTRA_IMAGE_FEATURES = “debug-tweaks package-management tools-profile tools-sdk tools-debug dev-pkgs”

The build fails during the do_rootfs task because an error is found in the log file. I attached the log file. At line 5448 I found the following errors:

mkdir: cannot create directory ‘/home/root’: Permission denied
cp: cannot stat '/usr/share/applications/gpio-tool.desktop': No such file or directory
Collected errors:
 * Solver encountered 1 problem(s):
 * Problem 1/1:
 *   - package libgl-imx-dev-1:6.2.2.p0-aarch32-r0.armv7at2hf-neon-mx6qdl requires libgl-mesa-dev, but none of the providers can be installed
 * 
 * Solution 1:
 *   - do not ask to install a package providing libgl-imx-dev

log.do_rootfs.5280

When I remove the dev-pkgs from EXTRA_IMAGE_FEATURES the build runs without errors. Also the LinuxImageV2.7 branch builds with dev-pkgs without errors.

I had to update to Rocko, because I need a Gstreamer version >= 1.10. I need the dev-pkgs for application development.

Thanks in advance for your help.

Regards,

Boris

Thanks for reporting, I was able to reproduce the issue on our end. It seems that mesa (and even the package) got properly built, but for some reason opkg seems not to like the package.

To get the image built for now you can disable that particular dependency in meta-toradex-nxp/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc by preceding the following line with ‘#’:

RDEPENDS_libgl-imx-dev += "libgl-mesa-dev"

Edit: Replace ‘uncomment’ with more verbose text.

I’ve got the same problem but the dependency is already uncommented.

@borisvr, did you resolve that issue?

HI Oscar

Which git branch are you using to compile the software? What changes have you done exactly in your local.conf? Could you share an issue log?

Hi Oscar,
uncommenting the line resolved my issue.