Apollox extension disable LAN connection

Hi,

as soon as I click the the “ApolloX Torizon” button in visual studio, the LAN disconnects.

Module : verdin imx8m plus
Development board : Verdin Development Board with HDMI Adapter
Host OS : Ubuntu 22.04.2 LTS
Visual studio code 1.81.1 + ApolloX extension

Behaviour:

  • Laptop boots → LAN is ok (see files ifconfig_before.txt and route_before.txt)
  • Launch visual studio code without any project loaded–> LAN is ok
  • click “ApolloX Torizon” button → LAN is disconnected after few seconds, internet connection lost and verdin module not found (see files if_config_after.txt and route_after.txt). The Apollox log is reported in the file apollox_log.txt
    route_before.txt (428 Bytes)
    route_after.txt (182 Bytes)
    ifconfig_before.txt (1.8 KB)
    ifconfig_after.txt (1.6 KB)
    apollox_log.txt (1.8 KB)

Could you please help me with this topic?

Best Regards

Hi @VMB ,

The IDE Extension 2 (formerly ApolloX) scans the local network to search for Toradex modules. It uses nmap and dig to do the scan.

Can you check if your local network has any type of restriction or security mechanism regarding the usage of nmap and dig?

Best regards,
Lucas Akira

Hi @lucas_a.tx,

thank you for the reply. I’m not sure if my local network complains when I use nmap and dig, but I think your hypothesis is valid. Actually I do not have the issue when I’m connected to other networks.
Is it possible to disable the scan? If possible, how can I do it?

Best Regards

Hi @VMB ,

Currently the extension doesn’t have an option to disable network scanning. I just made an internal request to add this feature in future releases of the extension. Thank you for your input!

Actually I do not have the issue when I’m connected to other networks.

That’s interesting to know. For now, can you use another network as a workaround?

Best regards,
Lucas Akira

Hi @lucas_a.tx,
Yes, I could insert a router between the company network and the host PC and the toradex device. In this way, I can circumvent the issue.

Best Regards

Hi @VMB ,

Just letting you know that the IDE Extension 2 now has an option to disable network scanning. In <project-directory>/.vscode/settings.json you need to add "torizon.autoScan": false, similar to the example below:

{
  "torizon_psswd": "",
  "torizon_login": "",
  "torizon_ip": "",
  "host_ip": "",
  "torizon_workspace": "${workspaceFolder}",
  "torizon_debug_port": "6512",
  "torizon_debug_ssh_port": "6502",
  "torizon_debug_port2": "",
  "torizon_debug_port3": "",
  "torizon_gpu": "",
  "torizon_arch": "",
  "wait_sync": "1",
  "torizon_run_as": "torizon",
  "torizon_app_root": "/home/torizon",
  "tcb.packageName": "python3pyside2qmltest",
  "tcb.version": "3.8.1",
  "torizon.autoScan": false
}

Best regards,
Lucas Akira