ApolloX Creating Production Docker image fails

Dear Toradex Support,

when trying to create the Docker Production image in the ApolloX VSCode extension the build fails with the following output:

 => CACHED [deploy 1/3] FROM docker.io/torizonextras/debian:2.5-bullseye@sha256:1d547c77c632933f764f0577ce67cd58f9b8d9e027b879512ae5f74e76cdba34                                             0.0s
 => CANCELED [deploy 2/3] RUN apt-get -y update && apt-get install -y --no-install-recommends  && apt-get clean && apt-get autoremove && rm -rf /var/lib/apt/lists/*                        21.5s
 => CACHED [build 2/5] RUN apt-get -q -y update &&     apt-get -q -y install     &&     apt-get clean && apt-get autoremove &&     rm -rf /var/lib/apt/lists/*                               0.0s
 => [build 3/5] COPY . /app                                                                                                                                                                  2.8s
 => [build 4/5] WORKDIR /app                                                                                                                                                                 1.7s
 => [build 5/5] RUN if [ arm == "arm64" ] ; then         make ARCH=. CC=aarch64-linux-gnu-g++ ;     elif [ arm == "arm" ] ; then         make ARCH=. CC=arm-linux-gnueabihf-g++ ;     elif  14.2s
 => ERROR [deploy 3/3] COPY --from=Build /app/debug /app                                                                                                                                     0.0s
 > [deploy 3/3] COPY --from=Build /app/debug /app:
failed to solve: failed to compute cache key: "/app/debug" not found: not found

I have currently tried to set up a clean new project but i still get the same error. What could be wrong?
I am using WSL on Windows and have Docker Desktop installed.

Thank you very much!

Hi @xlukem ,

I was able to reproduce your issue by creating a new C++ Console Application template using the current ApolloX version.

I will report this to the extension team for further analysis, and I’ll reply back here once I have any updates.

Best regards,
Lucas Akira

Hi @xlukem ,

This issue was a bug related to the Dockerfile generated by our C++ template and it has been fixed. Thanks for reporting it!

ApolloX has already been updated with this fix, so be sure to update the extension in VSCode.

Given that the default C++ template has changed, you need to create a new C++ project and copy all relevant files from your older project (source code, include files, etc.) to the new one.

Try doing the above and see if this solves the problem.

Best regards,
Lucas Akira

1 Like

Hey @lucas_a.tx ,

thank you very much for your help! I was now able to create a release version within the VSCode Extension.

I still had a bit of trouble installing the Extension Update. VSCode did not want to update to the new Version so I had to manually download and install it. I would guess this was due to Version 0.0.63 and 0.0.64 being only avalible for Linux x64 as it says here: Torizon IDE Experimental Extension - Visual Studio Marketplace

Regardless, thank you for your quick response and update.

Best regards,

Hi @xlukem ,

Thanks for confirming.

If you run into other issues, feel free to post them here.

Best Regards