Apalis Video SYNC Problem

I am using Apalis IMX6 with 5.3.0 Linux Reference Multimedia image.

gst-launch-1.0 videotestsrc pattern=18 ! imxg2dvideosink framebuffer=/dev/fb0

with that command the video’s video sync shifted.

resolution was 640x480@30

how can i solve that issue?

Hello @erdemkahraman ,

Thank you for your message.
Could you please tell us which display are you using and when do you particularly face this issue?

Does this occur only when using this command? Hav you tried to modify the Gstreamer pipeline?

BR, Janani

I am using as display “Vestel FHD Television” and i tried it another screen as “Samsung Monitor”, result didnt changed. Then i analyzed the HDMI lines at logic analyzer. The sync signals were shifting.

My command is really simple its only plays video at framebuffer.

I changed the resolution from u-boot terminal

setenv vidargs ‘video=mxcfb1:dev=hdmi,640x480M@30,if=RGB24’
saveenv

I tried that streaming again at 1920x1080@60. But the result didnt changed. Sync was not stable.

Hi @erdemkahraman

Which carrier board are you using?

Best regards,
Jaski

ixora v1.0A

Hi @erdemkahraman ,

Would it be possible for you to share more about the project which you are working on?

The carrier board you are using is a rather older version and depending on your use-case and to prevent further issues, it might be recommended to send you a newer version of the carrier.

Best Regards
Kevin